php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #10619 Apache is not able to load the php module
Submitted: 2001-05-02 16:35 UTC Modified: 2001-05-03 11:44 UTC
From: sonnysavage at yahoo dot com Assigned:
Status: Not a bug Package: Apache related
PHP Version: 4.0.5 OS: Windows NT 4.0 Build 1381
Private report: No CVE-ID: None
 [2001-05-02 16:35 UTC] sonnysavage at yahoo dot com
I have PHP being loaded as an Apache module.  I am using Apache 1.3.19.  I am using the standard Win32 binary release for both PHP and Apache.

Here is the line from my httpd.conf file:

LoadModule php4_module c:/php/sapi/php4apache.dll

I get this error message when trying to start apache:
=====================================================
Syntax error on line 182 of c:/program files/apache group/apache/httpd.conf:
Cannot load c:/php/sapi/php4apache.dll into server: (127) The specified procedure could not be found:

Note the errors or messages above, and press the (ESC) key to exit.
=====================================================

If I replace the 4.0.5 dll with version 4.0.4pl1, it works just fine.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-05-03 06:22 UTC] dbeu@php.net
unable to repsoduce in the same environment.
i guess you haven't replaced everything with the new build.
 [2001-05-03 10:06 UTC] sonnysavage at yahoo dot com
I tried again, and here are the steps that I took:

1) I uninstalled and removed all files for both PHP and Apache.  

2) I unzipped PHP 4.0.5, copied the "php.ini-dist" to "php.ini" in my WinNT folder, Rebooted, Installed Apache 1.3.19, added this line to my httpd.conf file "LoadModule php4_module c:/php/sapi/php4apache.dll" (as well as other configurations).

3) When starting Apache, I get the exact same error as before.

4) I replaced the 4.0.5 version of the php4apache.dll with the 4.0.4pl1 version, and Apache started without a hitch.
 [2001-05-03 11:09 UTC] sonnysavage at yahoo dot com
I have solved the problem.  I didn't copy the new php4ts.dll to my sys directory.

Another problem however is that the Zend optimizer doesn't work.  I have version 1.1.0 and it gives me a pile of errors.  I commented the zend lines out of my php.ini, and the php apache module loads fine now.
 [2001-05-03 11:11 UTC] sonnysavage at yahoo dot com
Here is a link to a similar thread on phpbuilder.com:
http://www.phpbuilder.com/forum/read.php3?num=3&id=104846&loc=0&thread=104846
 [2001-05-03 11:20 UTC] cynic@php.net
you don't need to have php4ts.dll in windows/system/, just leave it in the directory where apache.exe is.

Zend Optimizer is a third party product, report the errors to Zend.
 [2001-05-03 11:44 UTC] sonnysavage at yahoo dot com
I have isolated the cause of the problem(at least my problem).
In my case, I commented out the following line in php.ini
extension=php_mssql70.dll
Then the Apache crash does not happpen.
Hope this helps
 [2004-07-17 18:14 UTC] buzzcarter at hotmail dot com
Thanks... i just re-installed apache/php on WinXP and got the error described. Thanks to this post I discovered that an old copy of php4ts.dll was in my C:\WINDOWS\SYSTEM32

Once i replaced with the new version of php4ts.dll all works fine.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Tue Nov 24 20:01:23 2020 UTC