php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #10609 comments made with # or // in included files cause visible output
Submitted: 2001-05-02 09:31 UTC Modified: 2001-05-08 12:02 UTC
From: tummarel at ascu dot unian dot it Assigned:
Status: Closed Package: Scripting Engine problem
PHP Version: 4.0.5 OS: Linux
Private report: No CVE-ID: None
 [2001-05-02 09:31 UTC] tummarel at ascu dot unian dot it
using PHPnuke files are are often included inside others that are included as well. 
I had to change all the comments of my THEME.php file (the most internal include) otherwise they would produce output to the page! changing // and # to the /*  */ syntax "solve" the problem! note that this only happens in included files 
I can easily reproduce it if needed.

Only relevalnt to 4.0.5 was warking fine with 4.0.4

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-05-02 15:58 UTC] andi@php.net
Please post as short as possible reproducing scripts.
 [2001-05-02 16:05 UTC] andi@php.net
Please post as short as possible reproducing scripts.
(First update didn't get mailed out)
 [2001-05-02 16:41 UTC] tummarel at ascu dot unian dot it
Amazingly (i cant believe what i see) i was able to shorten the code that generates the bug (on my system, plainvalinnal redhat 6.1 running php 4.0.5 as a apache mod) to this code, note that the same code executes fine (of course) under 4.0.4; 

------------------------- example bug code
<?php
$YouCantSeeThisOne;
// After a // comment the source code gets dumped to the output.. look:
$YouCanSeeThis;
?>
------------------------- end example bug code

the ourput I get is :
// After a // comment the source code gets dumped to the output.. look: $YouCanSeeThis; 

 [2001-05-02 16:48 UTC] andi@php.net
I just can't reproduce this :)
Can you please post the output of flex --version.
Also maybe you can send the file that doesn't work as an attachement to php-dev@lists.php.net
 [2001-05-06 23:40 UTC] jmoore@php.net
I tried this with PHP NUke etc with 4.0.6 dev. Cant reproduce neither could about 10 other people, please tell us the version of flex you are using and email the file that causes the problem specifically to php-dev@lists.php.net or to jmoore@php.net

- James
 [2001-05-08 12:02 UTC] andi@php.net
This is fixed in the last CVS which supports "\r" as line ending. Please try the latest snapshot at snaps.php.net
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sun Apr 14 11:01:29 2024 UTC