php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #10594 "COM" command no longer works
Submitted: 2001-05-02 00:16 UTC Modified: 2001-05-02 23:03 UTC
From: interfac at bigpond dot net dot au Assigned:
Status: Closed Package: COM related
PHP Version: 4.0.5 OS: Windows NT/98
Private report: No CVE-ID: None
 [2001-05-02 00:16 UTC] interfac at bigpond dot net dot au
I have just upgraded from v4.0.4 and am having trouble with COM. I downloaded the WIN32 install for IIS (smaller version).

The command I had working in 4.0.4 was:
$ad = new COM("component");
This is a Visual Basic 6 DCOM component I had created and was looking at converting to a PHP/Web solution.

With v4.0.5, the application generates:
"dbg: Unable to initialise module
Module compiled with debug=0, thread-safety=1 module API=2001214
PHP compiled with debug=0, thread-safety=1 module API=200001222
These options need to match."
The web session hangs.

If I change "COM" to "com_load" I get the message above, plus the following message is displayed in the web session:
"Fatal error: Cannot instantiate non-existent class: com_load in C:\Inetpub\wwwroot\cc\testcom.php on line 118"


I would appreciate any assistance (or access to a copy of the WIN32 short install for version 4.0.4).

Thanks
James Organ

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-05-02 23:02 UTC] sniper@php.net
The com extension in 4.0.5 is broken. So staying with 4.0.4pl1 for now is safer.

Update to 4.0.6 when it's released.

--Jani

 [2001-05-02 23:03 UTC] sniper@php.net
Closed (not bogus)

--Jani

 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Mon May 27 12:01:26 2019 UTC