php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #10581 signal 6 when starting server
Submitted: 2001-05-01 11:43 UTC Modified: 2002-06-28 03:02 UTC
From: mark dot faine at msfc dot nasa dot gov Assigned:
Status: Not a bug Package: iPlanet related
PHP Version: 4.0.5 OS: Solaris 2.6
Private report: No CVE-ID: None
 [2001-05-01 11:43 UTC] mark dot faine at msfc dot nasa dot gov
My bug is exactly the same as Bug id #10012, except for my OS/PHP/Web server version differences.  I am getting exactly the same error.

I have set everything up correctly as stated in:
http://www.php.net/manual/en/install.netscape-enterprise.php

Error Message follows:

Status: 
[https-bc_devel]: start failed. (2: unknown early startup error)
[https-bc_devel]: server terminated (signal 6): watchdog is restarting it 
[https-bc_devel]: failure: server initialization failed 

Error
An error occurred during startup.
The server https-bc_devel was not started.
Return to process control 

Also, I don't even get that much when I try to start from the console. I get no error message at all, logs don't even say what the problem was?  Strange.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-05-01 14:47 UTC] mark dot faine at msfc dot nasa dot gov
My bug is exactly the same as Bug id #10012, except for my OS/PHP/Web server version
differences.  I am getting exactly the same error.

I have set everything up correctly as stated in:
http://www.php.net/manual/en/install.netscape-enterprise.php

Error Message follows:

Status: 
[https-bc_devel]: start failed. (2: unknown early startup error)
[https-bc_devel]: server terminated (signal 6): watchdog is restarting it 
[https-bc_devel]: failure: server initialization failed 

Error
An error occurred during startup.
The server https-bc_devel was not started.
Return to process control 

Also, I don't even get that much when I try to start from the console. I get no error
message at all, logs don't even say what the problem was?  Strange.

This is still not working, I'd go back to 4.0.4 pl1 but it's got it's own problems.  Anybody?
 [2001-05-01 15:00 UTC] avsm@php.net
Have you tried these entries in obj.conf ?

Init fn="load-modules" shlib="/path/to/server4/bin/libphp4.so" funcs="php4_init,php4_close,php4_execute,php4_auth_trans"
Init fn="php4_init" LateInit="yes"

These fix a library loading problem; if it doesn't fix yours, then we have to keep on searching.  Incidentally, what version of iPlanet are you running?
 [2001-05-01 15:16 UTC] avsm@php.net
User Feedback:

Yes, that was the first thing I tried, the server will start with these
changes but will timeout on every page, even non-php pages.  No page will
load.

It's Netscape iPlanet Server 4.0 SP5

 [2001-05-01 15:19 UTC] avsm@php.net
Hmm, need backtraces from gdb to show where things are going wrong ... is that possible? (not sure if you can get get debugging symbols from iPlanet)
 [2001-05-02 10:39 UTC] mark dot faine at msfc dot nasa dot gov
If this shows up more than once, I'm sorry, it seems I'm having trouble getting any messages through today.

Sorry, seems there was a core file, and since there was (and you didn't give me any choice) I went ahead and recompiled with debug and installed gdb and generated a backtrace.

Here it is:

(gdb) bt
#0  0xef114d1c in __sigprocmask () from /usr/lib/libthread.so.1
#1  0xef10ba44 in _resetsig () from /usr/lib/libthread.so.1
#2  0xef10b18c in _sigon () from /usr/lib/libthread.so.1
#3  0xef10dfe0 in _thrp_kill () from /usr/lib/libthread.so.1
#4  0xef07a5d8 in abort () from /usr/lib/libc.so.1
#5  0xee56cacc in ts_resource_read () at zend_ini_scanner_cc.cc:1695
#6  0xee56c7e0 in ts_resource_ex () at zend_ini_scanner_cc.cc:1695
#7  0xee4b8684 in php4_init () at zend_ini_scanner_cc.cc:1695
#8  0xef6624e0 in __0Fafunc_native_pool_wait_workPFP6GpblockP6HSessionP6HRequest_iUiP6GpblockP6HSessionP6HRequest ()
   from /export/home1/netscape/bin/https/lib/libns-httpd40.so
#9  0xef661b80 in __0FNfunc_exec_strP6KFuncStructP6GpblockP6HSessionP6HRequest ()
   from /export/home1/netscape/bin/https/lib/libns-httpd40.so
#10 0xef661e2c in INTfunc_exec () from /export/home1/netscape/bin/https/lib/libns-httpd40.so
#11 0xef65f974 in INTconf_run_init_functions () from /export/home1/netscape/bin/https/lib/libns-httpd40.so
#12 0x2eacc in __0FLmagnus_initP6KPRFileDescPCc ()
#13 0x2f204 in main ()
(gdb) 


 [2002-06-28 03:02 UTC] derick@php.net
Thank you for taking the time to report a problem with PHP.
Unfortunately your version of PHP is too old -- the problem
might already be fixed. Please download a new PHP
version from http://www.php.net/downloads.php

If you are able to reproduce the bug with one of the latest
versions of PHP, please change the PHP version on this bug report
to the version you tested and change the status back to "Open".
Again, thank you for your continued support of PHP.


 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Mon Jun 24 17:01:25 2019 UTC