php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #10517 suggestion for ease of use
Submitted: 2001-04-26 17:36 UTC Modified: 2002-02-09 23:36 UTC
From: johnadams78 at earthlink dot net Assigned:
Status: Duplicate Package: Feature/Change Request
PHP Version: 4.0.4 OS: all
Private report: No CVE-ID: None
 [2001-04-26 17:36 UTC] johnadams78 at earthlink dot net
like most programmers i'm lazy...  and hate wasting time looking for something.  so i have a suggestion that from my own experience i believe would save time.

section IV of the online maual..  the functions section..  many times you have to come back to this section to look up the syntax of a function..  but there are so many groups under this heading it's hard to find the one you're looking for.

why not add sub-headings to this section.  one for database related functions and the other for everything else.  ie.

IV. Function Reference
    I.  Database Related
        I.  Database (dbm-style) abstraction layer functions
        II. dBase functions
        III.MySQL Functions
        ....
    II. Everything Else
        I.  Apache-specific Functions
        II. Array Functions
        ....


just a suggestion..  would narrow down the number of headings the eye would have to scan through..  and help make it easier to find stuff faster.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-04-26 17:52 UTC] hholzgra@php.net
have been trying to do so every once in a while,
but the docbook DTD won't really let me

looks like we are going to tweak DTD and 
stylesheets ab bit :(
 [2001-05-12 13:29 UTC] jmoore@php.net
This is open not assigned.
 [2002-02-09 23:36 UTC] jimw@php.net
duplicate of #2352.
 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC