php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #10479 Failure to recognize libsybdb.so
Submitted: 2001-04-24 14:54 UTC Modified: 2001-06-04 04:27 UTC
From: code at ou dot edu Assigned:
Status: Closed Package: Installation problem
PHP Version: 4.0 Latest CVS (24/04/2001) OS: Solaris
Private report: No CVE-ID: None
 [2001-04-24 14:54 UTC] code at ou dot edu
Despite specification of --with-sybase=/sybase_dir ,
libphp4.so attempts to load /usr/local/lib/libsybdb.so , instead of /sybase_dir/lib/libsybdb.so . We checked the configure script, and it does configure the $SYBASE_LIBDIR correctly, so the problem must be in the make. Verified that this is the actual problem by putting a symlink in /usr/local/lib , libsybdb.so -> /sybase_dir/lib/libsybdb.so .

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-05-14 13:12 UTC] joey@php.net
Not a bug in sybase DB support, but in the configure/make process somewhere.
 [2001-06-04 04:27 UTC] sniper@php.net
Not any bug. You should set your LD_LIBRARY_PATH correctly.

--Jani

 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed Jul 06 05:05:45 2022 UTC