php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #10390 PHP CGI with AOLServer displays shebang
Submitted: 2001-04-18 21:03 UTC Modified: 2002-02-09 19:50 UTC
From: rfinnie at kefta dot com Assigned:
Status: Closed Package: Other web server
PHP Version: 4.0 Latest CVS (18/04/2001) OS: FreeBSD 3.4
Private report: No CVE-ID: None
 [2001-04-18 21:03 UTC] rfinnie at kefta dot com
This bug seems related to 9475.  When using perl, sh, etc on aolserver as a cgi, the output is normal.  However, if I use PHP compiled as a CGI (with #!/path/to/php as the first line), the shebang is displayed as the first line of the response after the headers are sent.

Configure line:
'./configure' '--prefix=/usr/local/rf_php' '--with-config-file-path=/usr/local/rf_php/lib' '--with-exec-dir=/usr/local/rf_php/bin' '--with-imap' '--with-gd=/usr/local' '--with-mysql=/usr/local/mysql' '--with-db' '--enable-discard-path'

Ryan Finnie

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-06-20 18:14 UTC] rfinnie at kefta dot com
Anybody?
 [2001-06-21 17:46 UTC] sniper@php.net
Duplicate of #9041

 [2002-02-09 19:50 UTC] mfischer@php.net
This bug has been fixed in CVS.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Mon Jun 17 21:01:30 2024 UTC