php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #10371 can't build libinformix.la from objects: /usr/ccs/lib/libgen.a
Submitted: 2001-04-17 23:57 UTC Modified: 2001-06-02 20:04 UTC
From: kevinhsu at sco dot com Assigned:
Status: Closed Package: Informix related
PHP Version: 4.0.4pl1 OS: UnixWare 7.1.1
Private report: No CVE-ID: None
 [2001-04-17 23:57 UTC] kevinhsu at sco dot com
Hi all,

Using SCO UnixWare 7.1.1,and trying to build php4.0.4pl1.
I use --with-informix , and --with-apxs option in
configure.
During my compiling, it goes wrong at :

------------
Making all in informix
        /bin/sh /pub/php-4.0.4pl1/libtool --silent --mode=link cc  -I. -I/pub/php-4.0.4pl1/ext/informix -I/pub/php-4.0.4pl1/main -I/pub/php-4.0.4pl1 -I/usr/loca
l/apache/include -I/pub/php-4.0.4pl1/Zend -I/usr/informix/incl/esql -I/pub/php-4
.0.4pl1/ext/mysql/libmysql -I/pub/php-4.0.4pl1/ext/xml/expat/xmltok -I/pub/php-4
.0.4pl1/ext/xml/expat/xmlparse -I/pub/php-4.0.4pl1/TSRM  -DUW=700 -DUSE_HSREGEX
-DUSE_EXPAT -DXML_BYTE_ORDER=12 -g -I/usr/informix/incl/esql   -o libinformix.la
  ifx.lo  /usr/ccs/lib/libgen.a
libtool: link: cannot build libtool library `libinformix.la' from non-libtool ob
jects: /usr/ccs/lib/libgen.a
*** Error code 1 (bu21)
UX:make: ERROR: fatal error.
*** Error code 1 (bu21)
UX:make: ERROR: fatal error.
*** Error code 1 (bu21)
UX:make: ERROR: fatal error.
*** Error code 1 (bu21)
UX:make: ERROR: fatal error.
---------------

Any idea?
Thanks

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-05-22 10:27 UTC] kevinhsu at sco dot com
from previous, I use the same steps to make it.
below is the answer from previous email
---------------------------
thx Paul Gardiner's help.
I use this steps to configure PHP4.0.4pl1 in UnixWare 711
system.

1.make sure we use gnu make/binutils/bison 1.28
2.configure Apache
3.set variables:
INFORMIXDIR=/usr/informix
INFORMIXSERVER=ids731
LD_LIBRARY_PATH=$INFORMIXDIR/lib:$INFORMIXDIR/lib/esql:$INFORMIXDIR/incl/esql

IFX_LIBS="-L$INFORMIXDIR/lib -L$INFORMIXDIR/lib/esql"
IFX_INCDIR=$INFORMIXDIR/incl/esql
IFX_LIBDIR="-L$INFORMIXDIR/lib -L$INFORMIXDIR/lib/esql"

**ps. If I don't set this, the "configure" will guess
the wrong information for IFX_LIBS. That's why we can't
make it.

4.configure PHP with informix support
./configure --with-apache=../apache_1.3.19 --without-mysql --with-informix=/usr/informix
--prefix=/usr/local/php

5.make / make install PHP
6.change back to Apache
7.set 2 variables
IFX_LIBS="-lifsql -lifasf -lifgen -lifos -lifgls \
-lcrypt_i /usr/ccs/lib/libgen.a -lsocket -lnsl -lm \
-lifglx -lc /usr/informix/lib/esql/checkapi.o"
LIBS="$IFX_LIBS"

8.configure apache
./configure --activate-module=src/modules/php4/libphp4.a

9. make / make install apache


 [2001-06-02 20:04 UTC] sniper@php.net
This should be fixed with PHP 4.0.6, please try the 
latest release candidate:

http://www.php.net/~andi/php-4.0.6RC2.tar.gz

-Jani

 
PHP Copyright © 2001-2018 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC