php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #10365 --with-dom option gets ignored
Submitted: 2001-04-17 14:48 UTC Modified: 2001-06-01 17:03 UTC
From: mmontero at mail dot communityconnect dot com Assigned:
Status: Not a bug Package: Compile Failure
PHP Version: 4.0.3pl1 OS: RedHat Linux 7
Private report: No CVE-ID: None
 [2001-04-17 14:48 UTC] mmontero at mail dot communityconnect dot com
We have over 100 servers running 4.0.3pl1 and we recently tried to install DOM support.  I am using the following configuration:

"./configure" \
"--with-config-file-path=/web/webny/adm/php" \
"--with-mysql=/opt/db/mysql/product/3.23.29a-gamma" \
"--with-oracle=/opt/db/oracle/product/current" \
"--with-mcrypt=/usr/local/lib" \
"--prefix=/web/webny/adm/php" \
"--with-oci8=/opt/db/oracle/product/current" \
"--with-curl=/usr/local/lib" \
"--with-xml" \
"--with-dom=/usr/local/lib" \
"--disable-posix" \
"$@"

It seems like the --with-dom option is not being honored, I get the following:

^[[1mConfiguring extensions^[[m
checking for ASPELL support... no
checking whether to enable bc style precision math functions... no
checking whether to enable calendar conversion support... no
checking CCVS Support... no
checking whether to include cpdflib support... no
checking for CURL support... yes
checking for CURL in default path... found in /usr/local
checking for CyberCash support... no
checking whether to enable DAV support through mod_dav... no
checking whether to include old xDBM support... no
checking whether to enable DBA... no
checking for GDBM support... no
checking for NDBM support... no
checking for Berkeley DB2 support... no
checking for Berkeley DB3 support... no
checking for DBM support... no
checking for CDB support... no
checking whether to enable DBA interface... no
checking whether to enable the bundled dbase library... no
checking whether to include DOM support... no

Is there a fix for this for THIS version of PHP?  We would prefer not to have to upgrade all of our machines.

Any help is appreciated.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-06-01 17:03 UTC] sniper@php.net
You are using wrong paths in the options.
Correct would be --with-dom=/usr/local

 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Tue Mar 31 20:01:24 2020 UTC