php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #10361 make don't work for Oracle 8i on 64bit Solaris kernel
Submitted: 2001-04-17 07:05 UTC Modified: 2001-11-14 13:14 UTC
From: Jens-Uwe dot Walther at force dot de Assigned:
Status: Closed Package: OCI8 related
PHP Version: 4.0.4pl1 OS: Solaris 5.7
Private report: No CVE-ID: None
 [2001-04-17 07:05 UTC] Jens-Uwe dot Walther at force dot de
ha-pollux(root)# uname -a
SunOS ha-pollux 5.7 Generic_106541-11 sun4u sparc SUNW,Ultra-60
ha-pollux(oracle)> svrmgrl

Oracle Server Manager Release 3.1.6.0.0 - Production

Copyright (c) 1997, 1999, Oracle Corporation.  All Rights Reserved.

Oracle8i Release 8.1.6.3.0 - Production
JServer Release 8.1.6.3.0 - Production

ha-pollux(root)# export CC=/opt/SUNWspro/bin/cc
ha-pollux(root)# export ORACLE_HOME=/u01/app/oracle/product/8.1.6
ha-pollux(root)# configure --prefix=/opt/php --with-oci8 --with-apxs=/opt/apache/bin/apxs [ --with-regex=apache ]

/bin/sh /software/compile/php/php-4.0.4pl1/libtool --silent --mode=compile /opt/SUNWspro/bin/cc  -I. -I/software/compile/php/php-4.0.
4pl1/ext/oci8 -I/software/compile/php/php-4.0.4pl1/main -I/software/compile/php/php-4.0.4pl1 -I/opt/apache/include -I/software/compil
e/php/php-4.0.4pl1/Zend -I/software/compile/php/php-4.0.4pl1/ext/mysql/libmysql -I/u01/app/oracle/product/8.1.6/rdbms/public -I/u01/a
pp/oracle/product/8.1.6/rdbms/demo -I/u01/app/oracle/product/8.1.6/network/public -I/software/compile/php/php-4.0.4pl1/ext/xml/expat/
xmltok -I/software/compile/php/php-4.0.4pl1/ext/xml/expat/xmlparse -I/software/compile/php/php-4.0.4pl1/TSRM  -D_POSIX_PTHREAD_SEMANT
ICS -DSOLARIS2=270 -DMOD_SSL=207101 -DEAPI -DUSE_EXPAT -DSHARED_CORE -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -DXML_BYTE_ORDER=21 -
g  -c oci8.c
"oci8.c", line 829: undefined struct/union member: open64
"oci8.c", line 845: undefined struct/union member: open64
"oci8.c", line 1203: undefined struct/union member: open64
"oci8.c", line 1204: improper member use: open64
"oci8.c", line 1205: improper member use: open64
"oci8.c", line 1849: undefined struct/union member: open64
"oci8.c", line 1962: undefined struct/union member: open64
"oci8.c", line 1995: undefined struct/union member: open64
"oci8.c", line 2087: undefined struct/union member: open64
"oci8.c", line 2131: undefined struct/union member: open64
"oci8.c", line 2174: undefined struct/union member: open64
"oci8.c", line 2189: undefined struct/union member: open64
"oci8.c", line 2190: improper member use: open64
"oci8.c", line 2194: improper member use: open64
"oci8.c", line 2200: improper member use: open64
"oci8.c", line 2351: undefined struct/union member: open64
"oci8.c", line 2792: warning: initializer does not fit or is out of range: -1
cc: acomp failed for oci8.c
*** Error code 1
make: Fatal error: Command failed for target `oci8.lo'
Current working directory /software/compile/php/php-4.0.4pl1/ext/oci8
*** Error code 1
make: Fatal error: Command failed for target `all-recursive'
Current working directory /software/compile/php/php-4.0.4pl1/ext/oci8
*** Error code 1
make: Fatal error: Command failed for target `all-recursive'
Current working directory /software/compile/php/php-4.0.4pl1/ext
*** Error code 1
make: Fatal error: Command failed for target `all-recursive'


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-10-20 21:40 UTC] sniper@php.net
Does this happen with PHP 4.0.6 ?

 [2001-11-10 08:43 UTC] sander@php.net
No feedback. Closing.
 [2001-11-14 13:14 UTC] mfischer@php.net
User reporting:
The problem is fixed with 4.0.6.  

(However, status unchanged ;-)
 
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Wed Mar 22 10:03:43 2023 UTC