php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #10290 magic_quotes_runtime setting varies at random
Submitted: 2001-04-11 12:14 UTC Modified: 2001-06-27 22:37 UTC
From: jhurshman at rocketmail dot com Assigned:
Status: Closed Package: PHP options/info functions
PHP Version: 4.0.4pl1 OS: Linux
Private report: No CVE-ID: None
 [2001-04-11 12:14 UTC] jhurshman at rocketmail dot com
magic_quotes_runtime (set in php.ini to off) seems to vary at random.

See http://www.sciocommunity.com/magic.php for an example. Hit reload several times; you should see the magic_quotes_runtime setting changing at random between 0 and 1.

See http://www.sciocommunity.com/magic.phps for the source. 

See http://www.sciocommunity.com/phpinfo.php for phpinfo() output.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-06-05 03:05 UTC] sniper@php.net
I can't reproduce this with PHP 4.0.6RC2. Please try
it from:

http://www.php.net/~andi/php-4.0.6RC2.tar.gz


--Jani

 [2001-06-27 22:37 UTC] sniper@php.net
No feedback and can't reproduce.


 [2003-04-03 04:33 UTC] ltastet at net-design dot fr
same problem with apache 1.3.26 + PHP 4.1.2 ( MySql + PostgreSql support ) + Zend Optimizer 2.1 on Linux Redhat 

in php.ini, magic_quotes are all at off, but randomly, I get backslashes on the screen !!

thanks for your help

best regards ...

Laurent TASTET
ltastet@net-design.fr
 [2003-08-22 05:46 UTC] salvador dot munoz at wanadoo dot fr
This problem is marked as "closed" but i do not see the solution.

I have the same problem in :

PHP Version 4.1.2
Linux rev66.cobalt 2.2.16C28_III #1 
Apache Version Apache/1.3.20 
Apache Release 10320100 
Apache API Version 19990320
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sun Nov 29 02:01:23 2020 UTC