php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #10274 I get an errormessage every time i use the ftp_support
Submitted: 2001-04-10 17:46 UTC Modified: 2001-04-11 07:56 UTC
From: redplayer at t-online dot de Assigned:
Status: Not a bug Package: FTP related
PHP Version: 4.0.3pl1 OS: SuSE Linux 7.1 Kernel 2.2.18
Private report: No CVE-ID: None
 [2001-04-10 17:46 UTC] redplayer at t-online dot de
This is my skript:

$ftp_user = "anonymous";
$ftp_pass = "anonymous";
$ftp_server = "redplayer.dynodns.net";
$ftp_port = 21

$conn_id = ftp_connect($ftp_server, $ftp_port);
$login_result = ftp_login($conn_id, $ftp_user, $ftp_pass);

if ((!$conn_id) || (!$login_result))
{
        echo "Ftp connection has failed!<br>\n";
        echo "Attempted to connect to $ftp_server for user $ftp_user";
        die;
}
else
{
        echo "Connected to $ftp_server, for user $ftp_user";
        
        $dir=ftp_pwd($connid);
        $list=Array();
        $list=ftp_nlist($connid, "$dir");
        $i=0;

        do
        {
        echo $list[$i], "";

        $i++;
        }
        while($list[$i]);
}

// END


Every time I want to start this skript i get an errormessage!

Here is the hole output:

Connected to redplayer.dynodns.net, for user anonymous
Warning: Unable to find ftpbuf 0 in /Data/www/ftpconn.php on line 36

Warning: Unable to find ftpbuf 0 in /Data/www/ftpconn.php on line 38

So, please mail me and say what I did wrong if it is not a bug!
Thanks


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-04-10 20:47 UTC] sniper@php.net
Could you please add a complete script into this bug report?
This one seems to be buggy and missing some parts?

Eg. after $ftp_port = 21 <--missing ;

--Jani

 [2001-04-11 06:59 UTC] redplayer at t-online dot de
Ok, this is my skript but i have forgotten to ad an ; at the end of the 4th line.

Now the complete skript:

$ftp_user = "anonymous";
$ftp_pass = "anonymous";
$ftp_server = "redplayer.dynodns.net";
$ftp_port = 21;

$conn_id = ftp_connect($ftp_server, $ftp_port);
$login_result = ftp_login($conn_id, $ftp_user, $ftp_pass);

if ((!$conn_id) || (!$login_result))
{
        echo "Ftp connection has failed!<br>\n";
        echo "Attempted to connect to $ftp_server for user $ftp_user";
        die;
}
else
{
        echo "Connected to $ftp_server, for user $ftp_user";
        
        $dir=ftp_pwd($connid);
        $list=Array();
        $list=ftp_nlist($connid, "$dir");
        $i=0;

        do
        {
        echo $list[$i], "";

        $i++;
        }
        while($list[$i]);

        ftp_quit($conn_id);
}

// END



 [2001-04-11 07:56 UTC] jmoore@php.net
We are not here to debug your scripts for you. Please slim this entire script down to the minimium that it requires to get the same error. This does not look like a bug, its also impossible to tell which lines are causing the error as the line numbers in the error given are different to the ones on the script.

php-general@lists.php.net is the correct location for asking help with your scripts not the bug system, please read bugs do's and donts before posting another bug, if this really is a bug reopen the report with a slimed down example script and the exact output when you run that script.

-James
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sun Nov 28 00:03:13 2021 UTC