php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #10244 Please put the dlopen weirdness in the FAQ
Submitted: 2001-04-09 11:42 UTC Modified: 2001-06-27 02:14 UTC
From: emil at styrke dot com Assigned:
Status: Not a bug Package: Documentation problem
PHP Version: 4.0.4pl1 OS: Linux 2.2.17
Private report: No CVE-ID: None
 [2001-04-09 11:42 UTC] emil at styrke dot com
I see this has been debated in previous bug reports, but it'd be really helpful to have the explanation in the FAQ, and maybe in the install docs too.

When starting apache with php, it segfaults when trying to unload the php dynamic library. One solution (although I haven't tried it), as mentioned in another bug report, is to recompile apache with -lpthreads. Another solution (at least it works for me) is to move the LoadModule php4_module directive and put it before any other LoadModule directives. This weirdness has been bugging me for days, so I _REALLY_ think it should be documented in at least one place..

/Emil

Config: ./configure --with-mysql=/usr --with-apxs

Backtrace:
#0  0x4000c887 in _dl_signal_error () from /lib/ld-linux.so.2
#1  0x401985d1 in _dl_close () from /lib/libc.so.6
#2  0x40198bd0 in _dl_close () from /lib/libc.so.6
#3  0x400a746b in dlopen () from /lib/libdl.so.2
#4  0x4000cafb in _dl_catch_error () from /lib/ld-linux.so.2
#5  0x400a780f in dlerror () from /lib/libdl.so.2
#6  0x400a7491 in dlclose () from /lib/libdl.so.2
#7  0x8067be9 in ap_os_dso_unload ()
#8  0x804f900 in ap_get_server_built ()
#9  0x8051bec in ap_run_cleanup ()
#10 0x8050c64 in ap_clear_pool ()
#11 0x805cb6a in ap_child_terminate ()
#12 0x805d31d in main ()
#13 0x400c5f5c in __libc_start_main () from /lib/libc.so.6

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-06-27 02:14 UTC] danbeck@php.net
This has nothing to do with documentation.  Please try again with the latest released version of PHP (4.0.6) or latest cvs and if the problem persists, take two asprin and resubmit this as a "Reproducable Crash" in the morning.
 
PHP Copyright © 2001-2018 The PHP Group
All rights reserved.
Last updated: Mon Dec 17 02:01:26 2018 UTC