php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #10233 Big file uploading problem form HTML FORM
Submitted: 2001-04-08 07:11 UTC Modified: 2001-10-28 17:21 UTC
From: csjang at mail dot knfc dot co dot kr Assigned:
Status: Closed Package: Apache related
PHP Version: 4.0.4pl1 OS: Window ME
Private report: No CVE-ID: None
 [2001-04-08 07:11 UTC] csjang at mail dot knfc dot co dot kr
I try file uploading using Apache + PHP under WINDOW ME.
I have set the my php.ini as following :

;;;;;;;;;;;;;;;;;;;
; Resource Limits ;
;;;;;;;;;;;;;;;;;;;
PHPRC=C:/WINDOWS  
max_execution_time = 600     ; Maximum execution time of each script, in seconds
memory_limit = 8M

post_max_size		=	100M

;;;;;;;;;;;;;;;;
; File Uploads ;
;;;;;;;;;;;;;;;;
file_uploads	= On				; Whether to allow HTTP file uploads
upload_tmp_dir	= D:/temp
upload_max_filesize = 100M

I could upload file sized 5.96 MB but could not upload 
above filesize,5.96 MB.
Maybe this is bug.
Please e-mail to me with solutions.

Good luck to you.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-04-08 07:26 UTC] derick@php.net
I don't think this is a bug, but that your script took more than 8MB of memory. Can you try changing your memory limit to a higher value?
 [2001-04-08 22:04 UTC] csjang at mail dot knfc dot co dot kr
REPLY to derick

I have considered your comments that my script took more than 8MB of memory. But the same problem occurred.
Exact error message from IE5.0 is "Can not display this page". I think FORM HTML problem. What can I do ?


ID: 10233
Updated by: derick
Reported By: csjang@mail.knfc.co.kr
Old-Status: Open
Status: Feedback
Bug Type: Apache related
Assigned To: 
Comments:

I don't think this is a bug, but that your script took more than 8MB of memory. Can you try changing your memory limit to a higher value?

Previous Comments:
---------------------------------------------------------------------------

[2001-04-08 07:11:16] csjang@mail.knfc.co.kr
I try file uploading using Apache + PHP under WINDOW ME.
I have set the my php.ini as following :

;;;;;;;;;;;;;;;;;;;
; Resource Limits ;
;;;;;;;;;;;;;;;;;;;
PHPRC=C:/WINDOWS  
max_execution_time = 600     ; Maximum execution time of each script, in seconds
memory_limit = 8M

post_max_size		=	100M

;;;;;;;;;;;;;;;;
; File Uploads ;
;;;;;;;;;;;;;;;;
file_uploads	= On				; Whether to allow HTTP file uploads
upload_tmp_dir	= D:/temp
upload_max_filesize = 100M

I could upload file sized 5.96 MB but could not upload 
above filesize,5.96 MB.
Maybe this is bug.
Please e-mail to me with solutions.

Good luck to you.

 [2001-04-09 02:47 UTC] derick@php.net
Duplicate of #10238
 [2001-10-28 17:21 UTC] sniper@php.net
This should be fixed in CVS now. You can try the latest 
development build from http://www.php4win.com/ but
make sure it's dated after 27th of October 2001.

Also, there are some minor leaks still in the new code.
If you encounter such leaks, please send the shortest
possible code + html with which you can reproduce the leak
to php-dev@lists.php.net (or me) so we can get rid of these leaks. 

This fix will be in PHP 4.2.0.

--Jani

 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed Dec 07 04:05:52 2022 UTC