php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #10187 Warning: mcrypt module initialization failed
Submitted: 2001-04-05 11:24 UTC Modified: 2001-09-09 06:09 UTC
From: clewis at myfonts dot com Assigned: derick (profile)
Status: Not a bug Package: mcrypt related
PHP Version: 4.0 Latest CVS (05/04/2001) OS: Mac OS X 10.0
Private report: No CVE-ID: None
 [2001-04-05 11:24 UTC] clewis at myfonts dot com
Using libmcrypt-2.4.10 on Mac OS X 10.0, compiled with 

--with-apache=/usr/local/src/apache_1.3.19 --with-mysql=/
usr/local --with-mcrypt --enable-track-vars --disable-debug


My sample script:

<?php

$stuff = mcrypt_cbc(MCRYPT_BLOWFISH,"This is my key","this 
is my message",MCRYPT_ENCRYPT);
print base64_encode($stuff);

?>

produces this error:

Warning: mcrypt module initialization failed in /Users/
clewis/dev/website/public/asdf.php on line 3


libmcrypt was compiled with --disable-posix-threads as 
suggested on the PHP mcrypt page.  

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-04-05 11:29 UTC] cmv@php.net
First, the "--disable-posix-threads" requirement for libmcrypt isn't a requirement anymore.  As of libmcrypt 2.4.x, you don't need it.

Second, I think you should be using the 2.4.x-style mcrypt functions.  Look at example 2 at http://www.php.net/manual/en/ref.mcrypt.php

Third, blowfish is broken in libmcrypt.  It will encode/decode internally, but don't rely on it if you need to pass data to a non-PHP application (e.g. Perl).


- Colin
 [2001-04-05 11:30 UTC] derick@php.net
Another mcrypt bug, I'll check this one out. It may be a platform depended bug BTW.
 [2001-04-05 11:30 UTC] derick@php.net
analysed > assigned
 [2001-04-05 11:48 UTC] clewis at myfonts dot com
Incidentally, I tried the new-style mcrypt functions as 
Colin suggested, and got a similar warning: "Could not open 
encryption module."

 [2001-05-01 03:37 UTC] derick@php.net
I guess this could be an OS specific problem. I've no access to a Mac OS X machine unfortunately.
 [2001-05-18 05:03 UTC] jmoore@php.net
Derick: Bug 10281 reports this on Linux. Probably not platform specific.
 [2001-09-09 06:09 UTC] sterling@php.net
not a php bug regardless of os
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sat Jun 12 10:01:24 2021 UTC