php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #10185 compile fails when using --with-oci8
Submitted: 2001-04-05 10:30 UTC Modified: 2001-11-14 11:14 UTC
From: xbezdek at fi dot muni dot cz Assigned:
Status: Closed Package: Compile Failure
PHP Version: 4.0.4pl1 OS: IRIX 6.5
Private report: No CVE-ID: None
 [2001-04-05 10:30 UTC] xbezdek at fi dot muni dot cz
When I try to compile with oci8 support, I get an error.

ORACLE Release is 8.1.5.0.1

Here is my ./configure command, and the output from make

#./configure --prefix=/tmp/php/php4
--with-config-file-path=/tmp/php/php4/conf --with-oci8

#make
Making all in .
        gcc  -I. -I/export/tmp/php/php-4.0.4pl1/
-I/export/tmp/php/php-4.0.4pl1/main
-I/export/tmp/php/php-4.0.4pl1
-I/export/tmp/php/php-4.0.4pl1/Zend
-I/export/tmp/php/php-4.0.4pl1/ext/mysql/libmysql
-I/packages/run/oracle81/OraHome1/rdbms/demo
-I/packages/run/oracle81/OraHome1/network/public
-I/packages/run/oracle81/OraHome1/plsql/public
-I/export/tmp/php/php-4.0.4pl1/ext/xml/expat/xmltok
-I/export/tmp/php/php-4.0.4pl1/ext/xml/expat/xmlparse
-I/export/tmp/php/php-4.0.4pl1/TSRM  -DXML_BYTE_ORDER=21 -g
-O2  -c stub.c && touch stub.lo
        /bin/sh /export/tmp/php/php-4.0.4pl1/libtool
--silent --mode=link gcc  -I.
-I/export/tmp/php/php-4.0.4pl1/
-I/export/tmp/php/php-4.0.4pl1/main
-I/export/tmp/php/php-4.0.4pl1
-I/export/tmp/php/php-4.0.4pl1/Zend
-I/export/tmp/php/php-4.0.4pl1/ext/mysql/libmysql
-I/packages/run/oracle81/OraHome1/rdbms/demo
-I/packages/run/oracle81/OraHome1/network/public
-I/packages/run/oracle81/OraHome1/plsql/public
-I/export/tmp/php/php-4.0.4pl1/ext/xml/expat/xmltok
-I/export/tmp/php/php-4.0.4pl1/ext/xml/expat/xmlparse
-I/export/tmp/php/php-4.0.4pl1/TSRM  -DXML_BYTE_ORDER=21 -g
-O2   -o libphp4.la -rpath /export/tmp/php/php-4.0.4pl1/libs
-L/packages/run/oracle81/OraHome1/lib  -R
/packages/run/oracle81/OraHome1/lib stub.lo  Zend/libZend.la
 sapi/cgi/libsapi.la  main/libmain.la  regex/libregex.la
ext/mysql/libmysql.la ext/oci8/liboci8.la
ext/pcre/libpcre.la ext/posix/libposix.la
ext/session/libsession.la ext/standard/libstandard.la
ext/xml/libxml.la  TSRM/libtsrm.la -ldl -lm -lexc -lgen -lm
-ldl -lcrypt -lsocket -lsocket -lclntsh
        /bin/sh /export/tmp/php/php-4.0.4pl1/libtool
--silent --mode=link gcc  -I.
-I/export/tmp/php/php-4.0.4pl1/
-I/export/tmp/php/php-4.0.4pl1/main
-I/export/tmp/php/php-4.0.4pl1
-I/export/tmp/php/php-4.0.4pl1/Zend
-I/export/tmp/php/php-4.0.4pl1/ext/mysql/libmysql
-I/packages/run/oracle81/OraHome1/rdbms/demo
-I/packages/run/oracle81/OraHome1/network/public
-I/packages/run/oracle81/OraHome1/plsql/public
-I/export/tmp/php/php-4.0.4pl1/ext/xml/expat/xmltok
-I/export/tmp/php/php-4.0.4pl1/ext/xml/expat/xmlparse
-I/export/tmp/php/php-4.0.4pl1/TSRM  -DXML_BYTE_ORDER=21 -g
-O2   -o php -export-dynamic      stub.lo libphp4.la
ld32: WARNING 84 : /usr/lib32/libdl.so is not used for
resolving any symbol.
ld32: WARNING 84 : /usr/lib32/libexc.so is not used for
resolving any symbol.
ld32: WARNING 84 : /usr/lib32/libgen.so is not used for
resolving any symbol.
ld32: WARNING 84 : /usr/lib32/libsocket.so is not used for
resolving any symbol.
ld32: FATAL   12 : Expecting n32 objects:
/packages/run/oracle81/OraHome1/lib/libclntsh.so is n64.
collect2: ld returned 4 exit status
*** Error code 1 (bu21)
*** Error code 1 (bu21)


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-10-23 07:27 UTC] sniper@php.net
Does this happen with PHP 4.0.6? Or with latest CVS snapshot
from http://snaps.php.net/ ?

--Jani

 [2001-11-14 06:38 UTC] sander@php.net
No feedback. Closing.
 [2001-11-14 11:14 UTC] xbezdek at fi dot muni dot cz
with PHP 4.0.6 I get the same errors... I don't try compile the latest CVS snapshot yet, so... no results

 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Mon Jun 17 08:01:32 2024 UTC