php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #10128 Undefined Variables
Submitted: 2001-04-03 00:39 UTC Modified: 2001-04-03 11:13 UTC
From: gabriel_kwok at yahoo dot com Assigned:
Status: Not a bug Package: IIS related
PHP Version: 4.0.4pl1 OS: Windows NT
Private report: No CVE-ID: None
 [2001-04-03 00:39 UTC] gabriel_kwok at yahoo dot com
On Unix, I don't need to declare variables.  With IIS, I try to check if a QUERY_STRING variables exists, with "if ($x != "") { echo $x; }".  It works fine on Unix, but with IIS, it says that $x is not defined.

I could check if it exists under the HTTP_GET_ variables ... but I don't want to go through that hassle.  Is this a bug with IIS? 

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-04-03 01:24 UTC] torben@php.net
No, it probably just means that you don't have the register_globals
option turned on. See the manual for more information:

http://www.php.net/manual/en/configuration.php#ini.register-globals

By the way, you should also check out:

  http://www.php.net/support.php

for information on asking questions about PHP; there are a lot of
bug reports and it helps if people ask to find out whether it really
might be a bug before reporting it as one.


 [2001-04-03 11:13 UTC] cynic@php.net
either that, or you have error_reporting set to E_ALL in php.ini. decrease the value.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed Dec 07 03:05:52 2022 UTC