php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #10090 PHP code parser interprets <? and ?> tags -IN- comments
Submitted: 2001-03-31 08:10 UTC Modified: 2001-03-31 08:12 UTC
From: chabotc at reviewboard dot com Assigned:
Status: Not a bug Package: Scripting Engine problem
PHP Version: 4.0.4pl1 OS: Redhat Linux 7.0
Private report: No CVE-ID: None
 [2001-03-31 08:10 UTC] chabotc at reviewboard dot com
When writing a piece of code, with a comment containing <? or ?>
the block statements are still interpreted by the script parser.

eg

<?
// this is a comment about ?> tags
echo "hello";
?>

would give you a syntax error when trying to run the script.

Since im writing a php source beautifier in PHP, this is kind of anoying :)

	-- Chris

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-03-31 08:12 UTC] cynic@php.net
read the manual. this is how it works.
 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC