php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #10077 after installing php-4.0.0, get error message "undefined symbol: mysql_init"
Submitted: 2001-03-30 10:58 UTC Modified: 2001-05-01 08:49 UTC
From: kglinux at yahoo dot com Assigned:
Status: Closed Package: Apache related
PHP Version: 4.0.0 OS: Linux Mandrake 7.0
Private report: No CVE-ID: None
 [2001-03-30 10:58 UTC] kglinux at yahoo dot com
Syntax error on line 207 of /usr/local/apache_1.3.12/conf/httpd.conf 
Cannot load /usr/local/apache_1.3.12/libexec/libphp4.so into server: /usr/local/apache_1.3.12/libexec/libphp4.so: undefined symbol: mysql_init ./bin/apachectl start: httpd cound not be started

both apache and mysql functioned properly prior to compile of php-4.0.0 and both will function fine if I comment out line 207. However, php files won't run in my browser from localhost but will run from file located on isp, (same file copied from local to server will run). This makes off line development difficult.

Any assistance would be greatly appreciated.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-03-30 11:09 UTC] hholzgra@php.net
first: why are you using the rather outdated 4.0.0 release?

second: what does your configure line look like?


 [2001-05-01 08:49 UTC] jmoore@php.net
No feedback, please update to 4.0.5 and try again.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sat Sep 21 21:01:26 2019 UTC