php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #10074 checkdnsrr always returns false
Submitted: 2001-03-29 23:58 UTC Modified: 2001-05-18 06:23 UTC
From: chet2000 at netscape dot net Assigned:
Status: Closed Package: Network related
PHP Version: 4.0.4pl1 OS: Windows 2000
Private report: No CVE-ID: None
 [2001-03-29 23:58 UTC] chet2000 at netscape dot net
Every call I make to checkdnsrr returns false on Win2k/IIS.  Same code behaves properly in linux.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-03-30 14:40 UTC] sniper@php.net
This is because of this line in ext/standard/dns.c:

#if HAVE_RES_SEARCH && !(defined(__BEOS__)||defined(PHP_WIN32))

I don't know whether windows has the necessary functions
to get this work. Possibly.

--Jani

 [2001-04-28 23:16 UTC] sniper@php.net
Duplicate of #5311

 [2001-05-18 05:02 UTC] jmoore@php.net
This function is not avalible under win32. PHP now returns the correct error to the user. It may be implemented at some point in the future.

- James
 [2001-05-18 06:23 UTC] derick@php.net
Assigned? I closed it now.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Wed Dec 08 02:03:34 2021 UTC