php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #10054 configure ends with attension
Submitted: 2001-03-29 09:51 UTC Modified: 2001-03-29 10:03 UTC
From: apurva_7800 at rediffmail dot com Assigned:
Status: Not a bug Package: *Configuration Issues
PHP Version: 4.0.4pl1 OS: Redhat 6.1
Private report: No CVE-ID: None
 [2001-03-29 09:51 UTC] apurva_7800 at rediffmail dot com
Dear Sir
I have redhat linux 6.1 with krb5 1.1.1-26 imap -2000-2.6 
apache 1.3.9. and php-4.0.4pl1
Now configure with --with-imap --with -kerberos 
give me error at the end and create debug.log and tell me to mail this at php-install@lists.php.net 
I am pasting my debug.log here
debug.log
------------------------------------------------------------
CONFIGURE:   './configure' '--with-imap' '--with-mysql' '--with-kerberos' '--with-gd' '--with-apxs=/usr/sbin/apxs' '--enable-track-vars' '--enable-magic-quotes' '--enable-debugger'
CC:         gcc
CFLAGS:     -g -O2
CPPFLAGS:    -DLINUX=2 -DUSE_EXPAT
CXX:        
CXXFLAGS:   
INCLUDES:    -I/usr/include/apache  -I$(top_builddir)/Zend -I/home/admin/php-4.0.4pl1/ext/mysql/libmysql
LDFLAGS:     -Wl,-rpath,/usr/kerberos/lib -L/usr/kerberos/lib
LIBS:       -lgssapi_krb5 -lkrb5 -lk5crypto -lcom_err -lgd -lresolv -lm -ldl -lcrypt -lnsl  -lresolv
DLIBS:      -lc-client 
SAPI:       apache
PHP_RPATHS:  /usr/kerberos/lib
uname -a:   Linux ns.eyes4web.com 2.2.16-3 #1 Mon Jun 19 18:10:14 EDT 2000 i686 unknown

gcc -o conftest -g -O2  -DLINUX=2 -DUSE_EXPAT  -Wl,-rpath,/usr/kerberos/lib -L/usr/kerberos/lib conftest.c -lgssapi_krb5 -lkrb5 -lk5crypto -lcom_err -lgd -lresolv -lm -ldl -lcrypt -lnsl  -lresolv 1>&5
/usr/bin/ld: cannot open -lgssapi_krb5: No such file or directory
collect2: ld returned 1 exit status
-----------------------------------------------------------
plesae help me.
Apurva Shah

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-03-29 10:03 UTC] sniper@php.net
You should be doing what the configure script told you:
Ask this on php-install@lists.php.net !

Hint: You propably don't have the kerberos-devel rpm
installed.

--Jani

 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Tue Nov 24 03:01:23 2020 UTC