php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #10006 Netscape Navigator 4.7 returns blank pages.
Submitted: 2001-03-26 19:08 UTC Modified: 2001-03-27 04:35 UTC
From: dthompson at ewu dot edu Assigned:
Status: Not a bug Package: IIS related
PHP Version: 4.0.4 OS: NT 4.0 SP 4
Private report: No CVE-ID: None
 [2001-03-26 19:08 UTC] dthompson at ewu dot edu
I have installed PHP 4.0.4 on an NT 4.0 server with SP4 applied.  IE4.0 - IE5.5 can access my php pages just fine but when I try to access those same pages with Netscape Navigator 4.7 I get an empty page.

PHPINFO follows:


PHP Version 4.0.4 

System Windows NT 4.0 build 1381 
Build Date Dec 20 2000 
Server API ISAPI 
Virtual Directory Support enabled 
Configuration File (php.ini) Path php.ini 
ZEND_DEBUG disabled 
Thread Safety enabled 

 This program makes use of the Zend scripting language engine:
Zend Engine v1.0.3, Copyright (c) 1998-2000 Zend Technologies

 


--------------------------------------------------------------------------------

PHP 4.0 Credits

--------------------------------------------------------------------------------

Configuration
PHP Core 
Directive Local Value Master Value 
allow_call_time_pass_reference
 On On 
allow_url_fopen
 1 1 
arg_separator
 & & 
asp_tags
 On On 
auto_append_file
 no value no value 
auto_prepend_file
 no value no value 
browscap
 no value no value 
default_charset
 no value no value 
default_mimetype
 text/html text/html 
define_syslog_variables
 Off Off 
disable_functions
 no value no value 
display_errors
 On On 
display_startup_errors
 Off Off 
doc_root
 no value no value 
enable_dl
 On On 
error_append_string
 Off Off 
error_log
 no value no value 
error_prepend_string
 Off Off 
error_reporting
 2039 2039 
expose_php
 On On 
extension_dir
 C:\InetPub\scripts\Php\extensions C:\InetPub\scripts\Php\extensions 
file_uploads
 1 1 
gpc_order
 GPC GPC 
highlight.bg
 #FFFFFF #FFFFFF 
highlight.comment
 #FF8000 #FF8000 
highlight.default
 #0000BB #0000BB 
highlight.html
 #000000 #000000 
highlight.keyword
 #007700 #007700 
highlight.string
 #DD0000 #DD0000 
html_errors
 On On 
ignore_user_abort
 Off Off 
implicit_flush
 Off Off 
include_path
 no value no value 
log_errors
 Off Off 
magic_quotes_gpc
 On On 
magic_quotes_runtime
 Off Off 
magic_quotes_sybase
 Off Off 
max_execution_time
 30 30 
open_basedir
 no value no value 
output_buffering
 Off Off 
output_handler
 no value no value 
post_max_size
 8M 8M 
precision
 14 14 
register_argc_argv
 On On 
register_globals
 On On 
safe_mode
 Off Off 
safe_mode_exec_dir
 no value no value 
sendmail_from
 me@localhost.com me@localhost.com 
sendmail_path
 no value no value 
short_open_tag
 On On 
SMTP
 localhost localhost 
sql.safe_mode
 Off Off 
track_errors
 On On 
upload_max_filesize
 2M 2M 
upload_tmp_dir
 no value no value 
user_dir
 no value no value 
variables_order
 EGPCS EGPCS 
y2k_compliance
 Off Off 


pgsql
PostgreSQL Support enabled 
Active Persistent Links 0 
Active Links 0 

Directive Local Value Master Value 
pgsql.allow_persistent
 On On 
pgsql.max_links
 Unlimited Unlimited 
pgsql.max_persistent
 Unlimited Unlimited 


db
flat file support enabled 


curl
CURL support enabled 
CURL Information libcurl 7.5.1 (SSL 0.9.6) 


sablot
Sablotron XSLT support enabled 


zlib
ZLib Support enabled 
Compiled Version 1.1.3 
Linked Version 1.1.3 


mssql
MSSQL Support enabled 
Active Persistent Links 0 
Active Links 0 
Library version 7.0 

Directive Local Value Master Value 
mssql.allow_persistent
 On On 
mssql.batchsize
 0 0 
mssql.compatability_mode
 Off Off 
mssql.connect_timeout
 5 5 
mssql.max_links
 Unlimited Unlimited 
mssql.max_persistent
 Unlimited Unlimited 
mssql.min_error_severity
 10 10 
mssql.min_message_severity
 10 10 
mssql.textlimit
 Server default Server default 
mssql.textsize
 Server default Server default 


interbase
Interbase Support enabled 
Revision $Revision: 1.48 $ 
Dynamic Module yes 
Allow Persistent Links Yes 
Persistent Links 0/unlimited 
Total Links 0/unlimited 
Timestamp Format %m/%d/%Y %H:%M:%S 
Date Format %m/%d/%Y 
Time Format %H:%M:%S 


imap
IMAP Support enabled 
IMAP c-Client Version 4.1 


domxml
DOM/XML, XPath, XPointer Support enabled 
libmxl Version 2.2.8 


cybercash
Cybercash Support enabled 


standard
Regex Library Bundled library enabled 
Dynamic Library Support enabled 
Internal Sendmail Support for Windows 4 enabled 

Directive Local Value Master Value 
assert.active
 1 1 
assert.bail
 0 0 
assert.callback
 no value no value 
assert.quiet_eval
 0 0 
assert.warning
 1 1 
safe_mode_allowed_env_vars
 PHP_ PHP_ 
safe_mode_protected_env_vars
 LD_LIBRARY_PATH LD_LIBRARY_PATH 
session.use_trans_sid
 1 1 
url_rewriter.tags
 a=href,area=href,frame=src,form=fakeentry a=href,area=href,frame=src,form=fakeentry 


bcmath
BCMath support enabled 


Calendar
Calendar support enabled 


com
Directive Local Value Master Value 
allow_dcom
 Off Off 
typelib_file
 no value no value 


ftp
FTP support enabled 


mysql
MySQL Support enabled 
Active Persistent Links 1 
Active Links 1 
Client API version 3.23.22-beta 

Directive Local Value Master Value 
mysql.allow_persistent
 On On 
mysql.default_host
 no value no value 
mysql.default_password
 no value no value 
mysql.default_port
 no value no value 
mysql.default_socket
 no value no value 
mysql.default_user
 no value no value 
mysql.max_links
 Unlimited Unlimited 
mysql.max_persistent
 Unlimited Unlimited 


odbc
ODBC Support enabled 
Active Persistent Links 0 
Active Links 0 
ODBC library Win32 

Directive Local Value Master Value 
odbc.allow_persistent
 On On 
odbc.check_persistent
 On On 
odbc.default_db
 no value no value 
odbc.default_pw
   
odbc.default_user
 no value no value 
odbc.defaultbinmode
 return as is return as is 
odbc.defaultlrl
 return up to 4096 bytes return up to 4096 bytes 
odbc.max_links
 Unlimited Unlimited 
odbc.max_persistent
 Unlimited Unlimited 


pcre
PCRE (Perl Compatible Regular Expressions) Support enabled 
PCRE Library Version 3.1 09-Feb-2000 


session
Session Support enabled 

Directive Local Value Master Value 
session.auto_start
 Off Off 
session.cache_expire
 180 180 
session.cache_limiter
 nocache nocache 
session.cookie_domain
 no value no value 
session.cookie_lifetime
 0 0 
session.cookie_path
 / / 
session.cookie_secure
 Off Off 
session.entropy_file
 no value no value 
session.entropy_length
 0 0 
session.gc_maxlifetime
 1440 1440 
session.gc_probability
 1 1 
session.name
 PHPSESSID PHPSESSID 
session.referer_check
 no value no value 
session.save_handler
 files files 
session.save_path
 C:\Inetpub\scripts\Php\sessiondata C:\Inetpub\scripts\Php\sessiondata 
session.serialize_handler
 php php 
session.use_cookies
 On On 


xml
XML Support active 


wddx
WDDX Support enabled 


ISAPI
Server Variable Value 
ALL_HTTP HTTP_ACCEPT:image/gif, image/x-xbitmap, image/jpeg, image/pjpeg, application/vnd.ms-excel, application/msword, application/vnd.ms-powerpoint, application/x-comet, */* HTTP_ACCEPT_LANGUAGE:en-us HTTP_CONNECTION:Keep-Alive HTTP_HOST:assessment.ewu.edu HTTP_ACCEPT_ENCODING:gzip, deflate HTTP_USER_AGENT:Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 4.0)  
CONTENT_LENGTH 0 
PATH_INFO /php/test.php 
PATH_TRANSLATED C:\InetPub\scripts\PHP\test.php 
REMOTE_ADDR 146.187.15.209 
REMOTE_HOST 146.187.15.209 
REQUEST_METHOD GET 
SCRIPT_NAME /php/test.php 
SERVER_NAME assessment.ewu.edu 
SERVER_PORT 80 
SERVER_PORT_SECURE 0 
SERVER_PROTOCOL HTTP/1.1 
SERVER_SOFTWARE Microsoft-IIS/3.0 
URL /php/test.php 


Additional Modules
mhash 
dbase 


Environment
Variable Value 
COMPUTERNAME ASSESSMENTSRVR 
ComSpec C:\WINNT\system32\cmd.exe 
NTRESKIT C:\NTRESKIT 
NUMBER_OF_PROCESSORS 1 
OS Windows_NT 
Os2LibPath C:\WINNT\system32\os2\dll; 
Path C:\WINNT\system32;C:\WINNT;C:\NTRESKIT;C:\NTRESKIT\Perl;C:\Program Files\SPSS Data Entry Network Server;C:\Program Files\SPSS Data Entry Web Server 
PROCESSOR_ARCHITECTURE x86 
PROCESSOR_IDENTIFIER x86 Family 6 Model 5 Stepping 1, GenuineIntel 
PROCESSOR_LEVEL 6 
PROCESSOR_REVISION 0501 
PWRCHUTE C:\Program Files\Pwrchute 
SystemDrive C: 
SystemRoot C:\WINNT 
USERPROFILE C:\WINNT\Profiles\Default User 
windir C:\WINNT 


PHP Variables
Variable Value 
PHP_SELF /php/test.php 
HTTP_SERVER_VARS["ALL_HTTP"] HTTP_ACCEPT:image/gif, image/x-xbitmap, image/jpeg, image/pjpeg, application/vnd.ms-excel, application/msword, application/vnd.ms-powerpoint, application/x-comet, */* HTTP_ACCEPT_LANGUAGE:en-us HTTP_CONNECTION:Keep-Alive HTTP_HOST:assessment.ewu.edu HTTP_ACCEPT_ENCODING:gzip, deflate HTTP_USER_AGENT:Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 4.0)  
HTTP_SERVER_VARS["CONTENT_LENGTH"] 0 
HTTP_SERVER_VARS["PATH_INFO"] /php/test.php 
HTTP_SERVER_VARS["PATH_TRANSLATED"] C:\\InetPub\\scripts\\PHP\\test.php 
HTTP_SERVER_VARS["REMOTE_ADDR"] 146.187.15.209 
HTTP_SERVER_VARS["REMOTE_HOST"] 146.187.15.209 
HTTP_SERVER_VARS["REQUEST_METHOD"] GET 
HTTP_SERVER_VARS["SCRIPT_NAME"] /php/test.php 
HTTP_SERVER_VARS["SERVER_NAME"] assessment.ewu.edu 
HTTP_SERVER_VARS["SERVER_PORT"] 80 
HTTP_SERVER_VARS["SERVER_PORT_SECURE"] 0 
HTTP_SERVER_VARS["SERVER_PROTOCOL"] HTTP/1.1 
HTTP_SERVER_VARS["SERVER_SOFTWARE"] Microsoft-IIS/3.0 
HTTP_SERVER_VARS["URL"] /php/test.php 
HTTP_SERVER_VARS["PHP_SELF"] /php/test.php 
HTTP_SERVER_VARS["HTTP_ACCEPT"] image/gif, image/x-xbitmap, image/jpeg, image/pjpeg, application/vnd.ms-excel, application/msword, application/vnd.ms-powerpoint, application/x-comet, */* 
HTTP_SERVER_VARS["HTTP_ACCEPT_LANGUAGE"] en-us 
HTTP_SERVER_VARS["HTTP_CONNECTION"] Keep-Alive 
HTTP_SERVER_VARS["HTTP_HOST"] assessment.ewu.edu 
HTTP_SERVER_VARS["HTTP_ACCEPT_ENCODING"] gzip, deflate 
HTTP_SERVER_VARS["HTTP_USER_AGENT"] Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 4.0) 
HTTP_SERVER_VARS["argv"] Array
(
)

 
HTTP_SERVER_VARS["argc"] 0 
HTTP_ENV_VARS["COMPUTERNAME"] ASSESSMENTSRVR 
HTTP_ENV_VARS["ComSpec"] C:\\WINNT\\system32\\cmd.exe 
HTTP_ENV_VARS["NTRESKIT"] C:\\NTRESKIT 
HTTP_ENV_VARS["NUMBER_OF_PROCESSORS"] 1 
HTTP_ENV_VARS["OS"] Windows_NT 
HTTP_ENV_VARS["Os2LibPath"] C:\\WINNT\\system32\\os2\\dll; 
HTTP_ENV_VARS["Path"] C:\\WINNT\\system32;C:\\WINNT;C:\\NTRESKIT;C:\\NTRESKIT\\Perl;C:\\Program Files\\SPSS Data Entry Network Server;C:\\Program Files\\SPSS Data Entry Web Server 
HTTP_ENV_VARS["PROCESSOR_ARCHITECTURE"] x86 
HTTP_ENV_VARS["PROCESSOR_IDENTIFIER"] x86 Family 6 Model 5 Stepping 1, GenuineIntel 
HTTP_ENV_VARS["PROCESSOR_LEVEL"] 6 
HTTP_ENV_VARS["PROCESSOR_REVISION"] 0501 
HTTP_ENV_VARS["PWRCHUTE"] C:\\Program Files\\Pwrchute 
HTTP_ENV_VARS["SystemDrive"] C: 
HTTP_ENV_VARS["SystemRoot"] C:\\WINNT 
HTTP_ENV_VARS["USERPROFILE"] C:\\WINNT\\Profiles\\Default User 
HTTP_ENV_VARS["windir"] C:\\WINNT 


PHP License
This program is free software; you can redistribute it and/or modify it under the terms of the PHP License as published by the PHP Group and included in the distribution in the file: LICENSE 

This program is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. 

If you did not receive a copy of the PHP license, or have any questions about PHP licensing, please contact license@php.net. 
 


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-03-27 04:35 UTC] sniper@php.net
1. You have some NULL output in your pages
2. There's some <table> without </table>

Anyway, if the pages work with IE then PHP works -> not a bug in PHP but in your script output.

--Jani

 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Thu Dec 01 14:05:55 2022 UTC