php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #9990 php forces the apache to wait for ever
Submitted: 2001-03-26 04:29 UTC Modified: 2002-08-13 22:54 UTC
From: frank at freestyling dot de Assigned:
Status: Not a bug Package: InterBase related
PHP Version: 4.0.4pl1 OS: freebsd 4.2 and 4.1
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
4 + 14 = ?
Subscribe to this entry?

 
 [2001-03-26 04:29 UTC] frank at freestyling dot de
workaround: apache 1.3.14 + ssl + interbase (firebird 1.0) + 4.04pl1

<?
function ib6_LogOn($username='',$password='',$connectto) {
  $conn = ibase_connect("/usr/interbase/$connectto", $username, $password,'ISO8859_1');

  if (!$conn || ibase_errmsg()) ib6_errorlogs();
  return $conn;
}

$conn = ib6_logn('test','test','test.gdb');
print "Connection $conn<br>\n";
ibase_close($conn);
?>

when exec, this small script in a very fast sequence, php forces the apache for ever.
the apache is still working fine, when u exec a script that doesn't use ib6.
the browser responses: Doc. contains no data (500)

php doesn't seem to disconnect the connection.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-03-26 16:58 UTC] frank at freestyling dot de
workaround: apache 1.3.14 + ssl + interbase (firebird 1.0) + 4.04pl1

<?
function ib6_LogOn($username='',$password='',$connectto) {
  $conn = ibase_connect("/usr/interbase/$connectto", $username, $password,'ISO8859_1');

  if (!$conn || ibase_errmsg()) ib6_errorlogs();
    return $conn;
}

$conn = ib6_logn('test','test','test.gdb');
print "Connection $conn<br>\n";
ibase_close($conn);
?>

when exec, this small script in a very fast sequence, php forces the apache for ever.
the apache is still working fine, when u exec a script that doesn't use ib6.
the browser responses: Doc. contains no data (500)

php doesn't seem to disconnect the connection.

but then the apace tries to free memory, which doesn't seem to make any
differences ...

[Tue Mar 27 01:01:37 2001] [info] [client 10.0.0.1] send timed out
interbase.c(761) :  Freeing 0x0821E824 (71 bytes), script=/www/htdocs/test.de/htdocs/test.html
./zend_execute.c(1517) :  Freeing 0x082101A4 (12 bytes), script=/www/htdocs/test.de/htdocs/test.html
./zend_execute.c(1653) :  Freeing 0x082102A4 (10 bytes), script=/www/htdocs/test.de/htdocs/test.html
zend_variables.c(127) : Actual location (location was relayed)
Last leak repeated 3 times
./zend_execute.c(1650) :  Freeing 0x082C24A4 (12 bytes), script=/www/htdocs/test.de/htdocs/test.html
Last leak repeated 4 times

 [2002-08-13 22:54 UTC] kalowsky@php.net
Thank you for taking the time to report a problem with PHP.
Unfortunately you are not using a current version of PHP -- 
the problem might already be fixed. Please download a new
PHP version from http://www.php.net/downloads.php

If you are able to reproduce the bug with one of the latest
versions of PHP, please change the PHP version on this bug report
to the version you tested and change the status back to "Open".
Again, thank you for your continued support of PHP.


 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sat Aug 08 06:01:26 2020 UTC