php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #9958 configure script does not link libldap into PHP
Submitted: 2001-03-23 12:00 UTC Modified: 2001-04-01 14:08 UTC
From: brinel at earthlink dot net Assigned:
Status: Closed Package: LDAP related
PHP Version: 4.0.4pl1 OS: Solaris 8 MU3
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: brinel at earthlink dot net
New email:
PHP Version: OS:

 

 [2001-03-23 12:00 UTC] brinel at earthlink dot net
The configure script, run with the '--with-ldap' does not link php with libldap . PHP will compile fine, but when you try to run apache (DSO module) you get this:

Cannot load /usr/local/apache/libexec/libphp4.so into server: ld.so.1: /usr/local/apache/bin/httpd: fatal: relocation error: 
file /usr/local/apache/libexec/libphp4.so:
symbol ldap_unbind_s: referenced symbol not found

manually linking libphp with -lldap corrects the problem.

NOTE: solaris 8 has ldap libraries included. I would think this should be the default behavior.

configure was run as follows:
./configure --with-mysql=/usr/local/mysql --with-apxs=/usr/local/apache/bin/apxs --with-imap=../imap-2000c --with-ldap

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-03-26 15:55 UTC] sniper@php.net
Could you please try the latest CVS snapshot from http://snaps.php.net/ ? 

I made a little modification to the configure and it should 
work now with the Solaris libldap.

--Jani

 [2001-04-01 14:08 UTC] sniper@php.net
Closed. Reopen if latest CVS snapshot doesn't fix this.

--Jani

 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Tue Oct 04 17:03:58 2022 UTC