php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #9935 seg fault - apache - repost
Submitted: 2001-03-22 12:48 UTC Modified: 2001-05-02 18:17 UTC
From: tdavis at birddog dot com Assigned:
Status: Closed Package: Apache related
PHP Version: 4.0 Latest CVS (22/03/2001) OS: Slackware 7.1
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: tdavis at birddog dot com
New email:
PHP Version: OS:

 

 [2001-03-22 12:48 UTC] tdavis at birddog dot com
A backtrace was requested from Jani.

I recompiled everything as instructed but the result looks the same on the backtrace.  I could not get a core file, so I continued as the instructions said and this is what I got again:

#0  0x0 in ?? ()
#1  0x422f19e8 in ?? ()
#2  0x422eb50a in ?? ()
#3  0x422d546b in ?? ()
#4  0x422d5620 in ?? ()
#5  0x422d5866 in ?? ()
#6  0x401735bc in getprotobyname_r () from /lib/libc.so.6
#7  0x40173438 in getprotobyname () from /lib/libc.so.6
#8  0x81f6679 in tcp_socket_open (sin=0xbfffa050, tmp=0xbfff9850 "?\032", 
    ctr=0xbfff984c, hst=0xbfff9c50 "mail.tconl.com", port=110)
    at tcp_unix.c:230
#9  0x81f6531 in tcp_open (host=0xbfffa4f8 "mail.tconl.com", service=0x0, 
    port=110) at tcp_unix.c:183
#10 0x81f02f1 in net_open_work (dv=0x83eab80, 
    host=0xbfffa4f8 "mail.tconl.com", service=0xbfffa87a "pop3", port=110, 
    portoverride=110, flags=0) at mail.c:5523
#11 0x81f02a7 in net_open (mb=0xbfffa4f8, dv=0x0, port=110, ssld=0x0, 
    ssls=0x83ba084 "*pop3s", sslp=995) at mail.c:5494
#12 0x820f6ba in pop3_open (stream=0x84cdce8) at pop3.c:328
#13 0x81e5845 in mail_open (stream=0x0, 
    name=0x850f774 "{mail.tconl.com:110/pop3}", options=0) at mail.c:1019
#14 0x80cb04f in imap_do_open (ht=3, return_value=0x84cfe84, this_ptr=0x0, 
    return_value_used=1, persistent=0) at php_imap.c:809
---Type <return> to continue, or q <return> to quit---
#15 0x80cb146 in php_if_imap_open (ht=3, return_value=0x84cfe84, this_ptr=0x0, 
    return_value_used=1) at php_imap.c:837
#16 0x819d223 in execute (op_array=0x8510a6c) at ./zend_execute.c:1494
#17 0x819d3f4 in execute (op_array=0x84d7af4) at ./zend_execute.c:1534
#18 0x816533f in zend_execute_scripts (type=8, file_count=3) at zend.c:743
#19 0x80be2bc in php_execute_script (primary_file=0xbffff83c) at main.c:1194
#20 0x8175c2b in apache_php_module_main (r=0x8489d10, display_source_mode=0)
    at sapi_apache.c:89
#21 0x80bb3fa in send_php ()
#22 0x80bb42c in send_parsed_php ()
#23 0x81a7973 in ap_invoke_handler ()
#24 0x81bb701 in process_request_internal ()
#25 0x81bb760 in ap_process_request ()
#26 0x81b2d81 in child_main ()
#27 0x81b2f2c in make_child ()
#28 0x81b3087 in startup_children ()
#29 0x81b36bc in standalone_main ()
#30 0x81b3e4f in main ()
#31 0x400cc577 in __libc_start_main () from /lib/libc.so.6

I have a feeling that I am not getting a good backtrace.  I cannot seem to get a core file.

Thank you
Terry

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-03-26 17:59 UTC] sniper@php.net
What is the version of glibc in your system?

--Jani

 [2001-03-26 18:07 UTC] tdavis at birddog dot com
libc-2.1.3 it looks like

thank you!
Terry
 [2001-04-01 14:30 UTC] sniper@php.net
Could you try updating your CVS checkout and do this:

'./cvsclean ; ./buildconf' 

And try generating that gdb backtrace again.
Oh, does this happen with some script? And is there
some other bug report about this? Which number?
Please add the shortest possible and self-containing 
script into this bug report that can be used to reproduce
this problem.

--Jani

 [2001-05-02 18:17 UTC] jmoore@php.net
No feedback. Closing

- James
 [2001-05-02 18:17 UTC] jmoore@php.net
No feedback. Closing

- James
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Thu Sep 19 19:01:27 2019 UTC