php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #9932 Finds wrong -lz if there are lots of build options
Submitted: 2001-03-22 11:41 UTC Modified: 2001-04-28 15:51 UTC
From: pete_lancashire at columbia dot com Assigned:
Status: Closed Package: Installation problem
PHP Version: 4.0.4pl1 OS: Solaris 7 Sparc
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: pete_lancashire at columbia dot com
New email:
PHP Version: OS:

 

 [2001-03-22 11:41 UTC] pete_lancashire at columbia dot com
System has libz in two places
  in /usr/openwin/lib
    /usr/openwin/lib/libz.so.1

  in /usr/local/lib
    /usr/local/lib/libz.so -> libz.so.1.1.3
    /usr/local/lib/libz.so.1 -> libz.so.1.1.3
    /usr/local/lib/libz.so.1.1.3

The following configure options find the correct libz
------------------
./configure \
 --with-apxs=/usr/local/apache/bin/apxs \
 --with-config-file-path=/usr/local/apache/httpd/conf \
 --enable-track-vars \
 --enable-ftp \
 --enable-bcmath=yes \
 --disable-debug \
 --enable-memory-limit=yes \
 --with-zlib=/usr/local 

The following generates the error
  checking whether to include zlib support... yes
  checking for gzgets in -lz... no
  configure: error: Zlib module requires zlib >= 1.0.9.
----------------------
./configure \
 --with-apxs=/usr/local/apache/bin/apxs \
 --with-config-file-path=/usr/local/apache/httpd/conf \
 --enable-track-vars \
 --with-zlib=/usr/local \
 --with-mysql=/usr/local/mysql \
 --enable-ftp \
 --with-tiff-dir=/usr/local \
 --with-jpeg-dir=/usr/local \
 --with-xpm-dir=/usr/X11R6 \
 --with-gd=/usr/local \
 --with-gdbm=/usr/local \
 --enable-bcmath=yes \
 --disable-debug \
 --enable-memory-limit=yes \
 --enable-calendar \
 --enable-magic-quotes \
 --with-db2=/usr/local/BerkeleyDB277 \
 --with-xml

I tried to eliminate one at a time different options but
when I find one that by removing it will let the process
finish, and then put that option into the above "success"
configure above, the configure will work. I.e. it is not
just one option causing the conflict.

Current work around is to not use zlib for now.

UPDATE: Removing the libz from /usr/openwin/lib works

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-03-26 17:58 UTC] sniper@php.net
Please check the config.log file for more info of what might be wrong.

--Jani

 [2001-04-28 15:51 UTC] jmoore@php.net
No feedback

closing.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sat Jul 13 22:01:29 2024 UTC