php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #9915 openssl_seal
Submitted: 2001-03-22 06:58 UTC Modified: 2001-04-06 09:24 UTC
From: pigo at pchome dot com dot tw Assigned:
Status: Not a bug Package: OpenSSL related
PHP Version: 4.0.4pl1 OS: Win2000 Professional
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: pigo at pchome dot com dot tw
New email:
PHP Version: OS:

 

 [2001-03-22 06:58 UTC] pigo at pchome dot com dot tw
I use document example

I can't run openssl_seal on win2000 pro , but linux is ok.
Other openssl function is ok , only openssl_seal can't encrypt data.

I use the same script and the same key on Linux, That's all no problem.

My platform :

Win2000 Profesional + Apache 1.3.19 + PHP4.0.4pl1 + mysql 3.23.33
Redhat 7.0 + Apache 1.3.17 + PHP4.0.4pl1 + mysql 3.22.32

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-03-27 11:20 UTC] pigo at pchome dot com dot tw
Now , I have fix it
Go to the site
http://www.stunnel.org/download/binaries.html

Download libssl32.dll and libseay32.dll
And change name libssl32.dll to SSLeay32.dll
copy libseay32.dll and SSLeay32.dll to WINNT/System32/


 [2001-04-06 09:24 UTC] wez@php.net
Not a bug in PHP but a lack of correctly configured/installed ssl DLLs. --> Bogus.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sun Nov 28 03:03:14 2021 UTC