php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #9906 Problems with result-set from temporary tables
Submitted: 2001-03-21 17:46 UTC Modified: 2001-07-26 02:19 UTC
From: nicolas at albisetti dot com dot ar Assigned:
Status: Closed Package: Sybase-ct (ctlib) related
PHP Version: 4.0.3pl1 OS: Linux RedHat 7.0
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: nicolas at albisetti dot com dot ar
New email:
PHP Version: OS:

 

 [2001-03-21 17:46 UTC] nicolas at albisetti dot com dot ar
I have some stored procedures that return a result from a temporary table. When via ct-lib i try to get the rows it didn?t return anything.
I try with the function sybase_query , and when i get the resource handler none of this functions give me any result:
sybase_num_rows, sybase_fetch_array,sybase_fetch_row.

the reproduction is easy just create a stored procedure that create, fill and select a temporary table.

if you use the php ct-lib functions they didn?t return any result.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-03-22 10:36 UTC] joey@php.net
I have a hard time believing that this is a PHP bug.

#1: Try upgrading to a newer release.
#2: Here is what I tried to test your bug:
 create proc phpb
 as
 begin
   create table #phpb (id int, foo varchar(255))
   insert into #phpb values (1, "a")
   insert into #phpb values (1, "a")
   insert into #phpb values (1, "a")
   insert into #phpb values (1, "a")
   insert into #phpb values (1, "a")
   insert into #phpb values (1, "a")
   insert into #phpb values (1, "a")
   insert into #phpb values (1, "a")

    select * from #phpb

end

PHP script looks like:
<?php

$db = sybase_connect(...);

$qu = sybase_query("phpb");

while ($a = sybase_fetch_array($qu)) {
        var_dump($a);
}
?>

I got the exact same result from both PHP and isql...
 [2001-06-26 17:07 UTC] joey@php.net
Have you tried my example? If so, what results do you
have? It may very well be that I simply didn't create
a complex enough example, or something, but I don't
see a bug, so this'll be closed if you don't have
anything further to add.
 [2001-07-26 02:19 UTC] andy@php.net
no feedback...
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Wed Mar 03 09:01:23 2021 UTC