php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #9896 segfaults at $xmldoc->add_root("root");
Submitted: 2001-03-21 06:08 UTC Modified: 2001-05-20 14:24 UTC
From: chregu at nomad dot ch Assigned:
Status: Closed Package: DOM XML related
PHP Version: 4.0 Latest CVS (21/03/2001) OS: Linux 2.4.2
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: chregu at nomad dot ch
New email:
PHP Version: OS:

 

 [2001-03-21 06:08 UTC] chregu at nomad dot ch
Reproduce with:

$xmldoc = domxml_new_xmldoc('1.0');
domxml_add_root($xmldoc,"bla");

Configure

./configure --with-config-file-path=/usr/local/apache/conf  --with-zlib  --with-mysql  --with-sablot --with-apxs=/usr/local/apache/bin/apxs --enable-versioning --with-dom=/opt/gnome

libxml2-2.3.3



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-03-21 15:27 UTC] sniper@php.net
Delete config.cache, add --enable-debug into your configure line, 'make clean ; make ; make install' and generate a GDB backtrace of the crash and add it into this bug report.

--Jani

 [2001-03-22 04:56 UTC] chregu at nomad dot ch
test-program:

$xmldoc = domxml_new_xmldoc('1.0');
$xmldoc->add_root("bla");


gdb backtrace:

Program received signal SIGSEGV, Segmentation fault.
0x401a3938 in objects () at zend_operators.c:1144
1144    }
(gdb) bt
#0  0x401a3938 in objects () at zend_operators.c:1144
#1  0x402c13e4 in php4_module () from /usr/local/apache/libexec/libphp4.so
#2  0x401d892a in objects () at php_domxml.c:668
#3  0x40199707 in objects () at ./zend_execute.c:853
#4  0x401aafc0 in objects () at zend.c:260
#5  0x401c3be3 in objects () at main.c:1126
#6  0x401bf11e in objects () at sapi_apache.c:98
#7  0x401bfe89 in objects () at mod_php4.c:437
#8  0x401bfed3 in objects () at mod_php4.c:437
#9  0x8074c09 in ap_invoke_handler ()
#10 0x808a0cf in process_request_internal ()
#11 0x808a142 in ap_process_request ()
#12 0x8080d96 in child_main ()
#13 0x8080f55 in make_child ()
#14 0x80810d6 in startup_children ()
#15 0x808175c in standalone_main ()
#16 0x8081f8c in main ()
#17 0x40096a8e in __libc_start_main () at ../sysdeps/generic/libc-start.c:93



 [2001-05-06 13:33 UTC] chregu@php.net
This still does not work in latest cvs (06/05/2001).
used another machine with libxml2-2.3.7 and linux-kernel 2.4.0. If one needs another backtrace, i can make one...

also 
$xml = xmldocfile("config.xml");
$root = domxml_root($xml);

produces a segfault (config.xml is a very simple xml file)


 [2001-05-07 12:56 UTC] derick@php.net
marking as fix before 4.0.6
 [2001-05-11 12:34 UTC] chregu@php.net
ok, there seems to be a massive api-change in domxml...
a lot, which worked in 4.0.5 seems not to work in 4.0.6
but for my former example, the following seems to work:

$doc = new_xmldoc("1.0");
$root = $doc->add_root("HTML");
echo $doc->dumpmem();

but this api-change makes me crazy. some things are easy to change (replace domxml_function($object,....) with $object->function(...), this works also with 4.0.5), but  the structure of the objects seem to have changed, too.. but maybe i missed something... otherwise i have to rewrite a lot of code and to check which version of php is used :=(
 [2001-05-20 14:24 UTC] jmoore@php.net
User reports this is fixed.

Closing

- James
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Wed Feb 26 05:01:26 2020 UTC