php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #9883 octal representation
Submitted: 2001-03-20 18:38 UTC Modified: 2001-03-21 01:05 UTC
From: koen at cee-kay dot net Assigned:
Status: Not a bug Package: *General Issues
PHP Version: 4.0.4pl1 OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: koen at cee-kay dot net
New email:
PHP Version: OS:

 

 [2001-03-20 18:38 UTC] koen at cee-kay dot net
Hi there,
I don't know if this is a bug, but while writing a form to enter lap times like: hours,minutes,seconds,milliseconds
milliseconds are likeley to start with a 0 (zero).

Now I found that this results in the Decimal value of the Octal-integer.

for example:
035 will be represented as: 29

Is this a bug or hidden feature? If this is not a bug, then is there any other way to pass a decimal value starting with a 0 (zero)?

Kind regards,
Koen Antonissen

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-03-21 01:05 UTC] derick@php.net
This is indeed a feature. You can strip the null from the
resulting string later, bu you have to do that by hand.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu Oct 28 06:03:33 2021 UTC