php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #9876 OCIPLogon flaky after restart Oracle
Submitted: 2001-03-20 11:55 UTC Modified: 2004-04-16 17:36 UTC
From: merrill at missioncriticallinux dot com Assigned:
Status: Not a bug Package: OCI8 related
PHP Version: 4.0.4pl1 OS: Redhat 6.1 Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: merrill at missioncriticallinux dot com
New email:
PHP Version: OS:

 

 [2001-03-20 11:55 UTC] merrill at missioncriticallinux dot com
./configure' '--prefix=/var/php' '--with-config-file-path=/var/php' '--enable-track-vars'
                                          '--enable-sigchild' '--with-apache=../apache_1.3.14' '--with-ftp' '--with-xml'
                                          '--with-mcrypt=/var/libmcrypt' '--with-pgsql=/var/postgresql'
                                          '--with-oci8=/u01/app/oracle/product/8.1.6' '--with-mysql=/var/mysql'

When using OCIPLogon for persistent connections, I'm noticing that after restarting Oracle, that my PHP application starts getting Oracle errors(ORA-03113 and ORA-03114).  This can be fixed by restarting the webserver after restarting Oracle.  I also notice that changing my Oracle connections from OCIPLogon to OCILogon fixes the problem - after making that change I get no errors after restarting Oracle, and I *don't* have to restart the webserver.

The OCI8 interface must have a bug, right?  I shouldn't have to restart the webserver after restarting Oracle just because I'm using persistent connections, should I?

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-04-08 22:53 UTC] bmironov at jonview dot com
Hello,

I have same problem under
RedHat 6.1 / 7.2
Oracle 7.3.4 / 8.1.5
PHP 4.1.2  (--with-oci8)
Apache 1.3.23

I have to restart whole webserver after Database restart. I would like to use OCIPLogon because of performance issue for very small SELECT's.
 [2003-11-18 05:03 UTC] aferaud at buyingpack dot com
PHP 4.3.3 (Linux) - Oracle 8.1.7 (Win2000)
I've have the same problem, and it still persists with non-persistent connection...

Is there a solution somewhere ??
 [2004-03-23 14:31 UTC] gid at gifpaste dot net
I've noticed this as well using cgi mode to run a daemon written in php.  My daemon runs 24/7.  If the database goes down when my daemon is running, sometimes it's able to reconnect, other times it isn't.  Calling OCINLogon() instead of OCILogon() helps, but not always, sometimes it simply refuses to reconnect until I restart my daemon.  Not a big deal, since our production database rarely goes down, but I thought I'd mention it.  I'll post more info here if I get it.

php 4.3.4, oracle 9.2.0.4.0
 [2004-03-24 02:22 UTC] tony2001@php.net
See bug #26829.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Thu Jan 23 05:01:24 2020 UTC