php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #9830 There is a problem with HTTP POST method.
Submitted: 2001-03-19 04:03 UTC Modified: 2001-04-19 09:32 UTC
From: serg at spylog dot ru Assigned:
Status: Closed Package: HTTP related
PHP Version: 4.0.4pl1 OS: Suse Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: serg at spylog dot ru
New email:
PHP Version: OS:

 

 [2001-03-19 04:03 UTC] serg at spylog dot ru
Here comes POST request:

>telnet www.spylog.ru 80
-----------------
POST /log_post.phtml HTTP/1.1
Host: www.spylog.ru
Content-Length: 32

12345678901234567890123456789012
-----------------

The answer to this request is random :-) Sometimes 200, sometimes just connection close!
But If I use perl - it works fine!

>telnet www.spylog.ru 80
-----------------
POST /cgi-bin/main.pl HTTP/1.1
Host: www.spylog.ru
Content-Length: 32

12345678901234567890123456789012
-----------------



Sometimes it seems that script works, but if I reads info from STDIN to a file - the file is empty. The same with Perl work's fine. I think it is a bug.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-03-19 11:59 UTC] sniper@php.net
Please try the latest CVS snapshot from 
http://snaps.php.net/ as there have been fixes in the
post handling since 4.0.4pl1 was released.

--Jani

 [2001-04-19 09:32 UTC] sniper@php.net
No feedback and should be fixed.

--Jani

 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Fri Dec 13 12:01:26 2019 UTC