php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #9815 cannot include/require files on network shares
Submitted: 2001-03-17 23:30 UTC Modified: 2001-05-11 20:55 UTC
From: djanix at hotmail dot com Assigned:
Status: Closed Package: Filesystem function related
PHP Version: 4.0 Latest CVS (17/03/2001) OS: win32
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: djanix at hotmail dot com
New email:
PHP Version: OS:

 

 [2001-03-17 23:30 UTC] djanix at hotmail dot com
using latest exe from php4win.de...
php cannot open network shares like
include( '\\\\computer\\c$\\php4\\include\\template.php' );
or
include( '\\computer\c$\php4\include\template.php' );
or
include( '//computer/c$/php4/include/template.php' );
or
include( '\\\\computer\c$/php4/include/template.php' );

nothing seems to work.

even with no include_path set...

i searched through the source to find how include calls fopen to see if i could offer any advice... i ran out of time when i was working on it, so i thought i might add a note here about it.  

there are so many layers of code involved in the fopen process... 

thank you so much for all of your time and work !  php is the greatest :)

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-03-18 18:18 UTC] sniper@php.net
Duplicate of #6554

--Jani


 [2001-05-11 20:55 UTC] sniper@php.net
Fixed in CVS. Fix will be in PHP 4.0.6.

--Jani

 
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Wed Feb 08 01:03:53 2023 UTC