php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #9809 Extensions can't be loaded at startup
Submitted: 2001-03-17 11:48 UTC Modified: 2001-03-17 18:45 UTC
From: loic-info at netcourrier dot com Assigned:
Status: Closed Package: *Configuration Issues
PHP Version: 4.0 Latest CVS (17/03/2001) OS: win 98SE
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: loic-info at netcourrier dot com
New email:
PHP Version: OS:

 

 [2001-03-17 11:48 UTC] loic-info at netcourrier dot com
Hi!

I'm under Win 98SE, Apache 1.3.19 and php4.0.5-RC1 (from www.php4win.de) as an Apache module ("php4apache.dll" or "php4apache-eapi.dll", the problem is the same for both).

It seems that extensions can't be loaded at startup (from the "php.ini" file) because their filenames are replaced by.... strange words!

For example if I uncomment the line "extension=php_zlib.dll" and only this one, Apache crash and the Apache log shows "PHP Warning:  Unable to load dynamic library 'C:\EasyPHP\php\extensions\php_zlib!'" 
(sometimes the name of the file is also replaced by 'localhost' or '@E').
This was an example, but I can reproduce the problem for each one of the extensions.

It's not related to my "php.ini" file because this one works with the previous version of php4.0.5-dev.

Thanks in advance,
Lo?c

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-03-17 12:35 UTC] loic-info at netcourrier dot com
Ok, a fix has been posted to the developer mailing-list (message from Alexander Bokovoy on On Sat, Mar 17, 2001 at 16:51).

So I close myself the bug.
Thanks,
 [2001-03-17 16:44 UTC] sniper@php.net
Reopened: This has not been fixed yet.

--Jani



 [2001-03-17 18:45 UTC] sniper@php.net
Fixed in CVS. 

--Jani

 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Fri Mar 01 19:01:33 2024 UTC