php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #9716 internal_functions.c:32: `#include' expects "FILENAME" or <FILENAME>
Submitted: 2001-03-12 20:42 UTC Modified: 2001-03-30 10:22 UTC
From: lon at mojomonkey dot com Assigned:
Status: Closed Package: Installation problem
PHP Version: 4.0 Latest CVS (12/03/2001) OS: Mac OS X RC1
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: lon at mojomonkey dot com
New email:
PHP Version: OS:

 

 [2001-03-12 20:42 UTC] lon at mojomonkey dot com
After configuration the this error occurs"

Making all in main
/bin/sh /Users/Shared/php4-200103121645/libtool --silent --mode=compile cc  -I. -I/Users/Shared/php4-200103121645/main -I/Users/Shared/php4-200103121645/main -I/Users/Shared/php4-200103121645 -I/usr/include/httpd -I/Users/Shared/php4-200103121645/Zend -I/usr/local/mysql/include/mysql -I/Users/Shared/php4-200103121645/ext/xml/expat/xmltok -I/Users/Shared/php4-200103121645/ext/xml/expat/xmlparse -I/Users/Shared/php4-200103121645/TSRM  -traditional-cpp -DDARWIN -DUSE_HSREGEX -DUSE_EXPAT -DSUPPORT_UTF8 -DXML_BYTE_ORDER=21 -g -O2  -c internal_functions.c
internal_functions.c:32: `#include' expects "FILENAME" or <FILENAME>
make[2]: *** [internal_functions.lo] Error 1
make[1]: *** [all-recursive] Error 1
make: *** [all-recursive] Error 1

This error is caused by the following line:

#include "ext/mysql/php_mysql.h"n#include "ext/pcre/php_pcre.h"n#include "ext/posix/php_posix.h"n#include "ext/session/mod_mm.h"n#include "ext/session/php_session.h"n#$
p_zlib.h"n

This line should be broken into multiple lines:

#include "ext/mysql/php_mysql.h"
#include "ext/pcre/php_pcre.h"  
#include "ext/posix/php_posix.h"
#include "ext/session/mod_mm.h"
#include "ext/session/php_session.h"  
#include "ext/standard/php_standard.h"
#include "ext/xml/php_xml.h"
#include "ext/zlib/php_zlib.h" 

The file can be manually edited after configuration and the build will proceed normally with success. However running configuration again will revert this file to the broken state again.



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-03-30 10:22 UTC] sas@php.net
Fixed in CVS. Thanks for your report.
 
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Wed Mar 22 04:03:45 2023 UTC