php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #9715 Memory leak when passing string values to modular variables in COM
Submitted: 2001-03-12 19:56 UTC Modified: 2001-03-13 22:08 UTC
From: Jason at hspace dot net Assigned:
Status: Not a bug Package: COM related
PHP Version: 4.0 Latest CVS (12/03/2001) OS: Windows 2000
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
33 - 32 = ?
Subscribe to this entry?

 
 [2001-03-12 19:56 UTC] Jason at hspace dot net
This is a new bug that I found.

Memory is leaked when passing string values to String variables in the modular scope of the COM object.

Example:

COM object has public variable called temp which is of String data type.

I instantiate the COM object and reference it with $t_obj.
I pass a string value from php like this:-

$t_obj->temp = "This is a test string.";

PHP has many other bugs concerning passing values through COM, but this bug is more serious because I am only trying to pass String values to the variables directly, without having to call a method to pass the values to the variables.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-03-12 22:02 UTC] Jason at hspace dot net
Found the problem.
It only leaks memory, if I pass a CONSTANT from PHP to the COM object.
All I have to do now is rewrite the php so that I'm passing a variable, not a constant.

Probably this issue can be closed after someone has a look into it.
 [2001-03-12 22:17 UTC] Jason at hspace dot net
That wasn't it... I tried it without passing a constant, and it's still leaking memory! So this is an outstanding serious bug with no workaround.
 [2001-03-13 22:08 UTC] sniper@php.net
submitted twice

 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sat May 21 02:03:37 2022 UTC