php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #9683 XML DOM memory leak w/ libxml 2.3.3
Submitted: 2001-03-11 15:13 UTC Modified: 2001-12-03 00:09 UTC
From: bryan at dunsinane dot net Assigned:
Status: Closed Package: DOM XML related
PHP Version: 4.0.4pl1 OS: Linux (Mandrake 7.2)
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: bryan at dunsinane dot net
New email:
PHP Version: OS:

 

 [2001-03-11 15:13 UTC] bryan at dunsinane dot net
Environment:
Linux (Mandrake 7.2)
Apache

Behavior:
I tested with both libxml 2.2.7 and libxml 2.3.4.  I have 
seen reports of this elsewhere.  I am not familiar with 
how to verify memory leaks.  When using libxml 2.3.4, 
apache processes increased in size until the apache locked 
up and become inaccessible.  Can't reproduce this using 
apache 2.2.7.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-03-12 18:36 UTC] bryan at dunsinane dot net
Last sentence of original bug should be:

Can't reproduce this using libxml 2.2.7.
 [2001-11-21 18:59 UTC] mfischer@php.net
Can you try latest RC and see if the problem still exists

http://www.php.net/~zeev/php-4.1.0RC3.tar.gz

Feedback.

 [2001-12-03 00:09 UTC] mfischer@php.net
Most leaks should be fixed in CVS.

If you still find any, re-open and paste short, self-containing sample script.

Closing.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Wed Sep 30 15:01:27 2020 UTC