php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #9589 Compile failure with glibc 2.1.2 and 2.4.2 kernel
Submitted: 2001-03-06 16:01 UTC Modified: 2001-03-06 16:07 UTC
From: chrish at gmx dot co dot uk Assigned:
Status: Not a bug Package: Compile Failure
PHP Version: 4.0.4pl1 OS: Linux
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: chrish at gmx dot co dot uk
New email:
PHP Version: OS:

 

 [2001-03-06 16:01 UTC] chrish at gmx dot co dot uk
Compiling PHP with a fairly old version of glibc (2.1.2) on
the new 2.4.X (specifically 2.4.2) series of Linux kernels
fails. It seems to be necessary to upgrade to at least 2.1.3
of glibc before compiling under 2.4.X kernel, even though it
is possible to compile PHP with glibc 2.1.2 under a 2.2.X
kernel without problems.

It would be nice if this was documented better, and perhaps
a check added to the ./configure script to ensure that this
potential problem was recognised.

The distribution is fairly heavily customised Mandrake 7.0.
I solved the problem by upgrading to glibc 2.1.3 with an RPM
from Mandrake 7.2.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-03-06 16:07 UTC] derick@php.net
Submitted twice
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri Apr 10 07:01:23 2020 UTC