php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #9579 POST method not performing action handler (ISAPI)
Submitted: 2001-03-06 10:08 UTC Modified: 2002-02-02 06:42 UTC
Votes:2
Avg. Score:4.0 ± 1.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: rhanic at husky dot ca Assigned:
Status: No Feedback Package: IIS related
PHP Version: 4.0.4pl1 OS: NT4.0 ISAPI
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please — but make sure to vote on the bug!
Your email address:
MUST BE VALID
Solve the problem:
30 + 49 = ?
Subscribe to this entry?

 
 [2001-03-06 10:08 UTC] rhanic at husky dot ca
Create a form and use method = POST with an action to another php script. The initial form is displayed properly but when you press the submit button a HTTP 500 internal server error message is displayed indicating that the action script (action=myscript.php) isn't found.
If I replace the POST with a GET this form works properly.

<form action=myscript.php method=POST>
<input type="Submit" name="submit" value="Update" class="BUTTON">

Web Server:IIS4 
NT 4.0 Service Pack 6
ISAPI installation



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-01-12 06:57 UTC] lobbin@php.net
Can you produce this with 4.1.1?
 [2002-02-02 06:42 UTC] sander@php.net
No feedback was provided for this bug, so it is being suspended.
If you are able to provide the information that was requested,
please do so and change the status of the bug back to "Open".
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Thu Aug 18 20:05:44 2022 UTC