php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #9551 False boolen input/output doesn't work
Submitted: 2001-03-04 17:11 UTC Modified: 2001-03-19 17:14 UTC
From: alain at samoun dot net Assigned:
Status: Closed Package: COM related
PHP Version: 4.0 Latest CVS (04/03/2001) OS: win32
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: alain at samoun dot net
New email:
PHP Version: OS:

 

 [2001-03-04 17:11 UTC] alain at samoun dot net
       $COMOBJ =New COM ("whatever");
        $COMOBJ->SetBoolean= False;   #Or 0
        $Test = $COMOBJ->SetBoolean;
        Print "test=" . $Test;  
        #$Test="" always empty
        #Note: Set to True or 1 returns 1 and is OK


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-03-19 17:14 UTC] phanto@php.net
this is not a bug, this is how php handles booleans.

try echo gettype($COMOBJ->SetBoolean);
or echo (int)$COMOBJ->SetBoolean;
and you'll see that all is right :)

 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sun Jul 21 09:01:26 2019 UTC