php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #9530 Apache will not start with PayFlow Pro SDK
Submitted: 2001-03-02 16:23 UTC Modified: 2001-05-01 01:11 UTC
From: rcovell at rolet dot com Assigned: jdonagher (profile)
Status: Closed Package: Verisign Payflow Pro related
PHP Version: 4.0.4pl1 OS: Slackware 7.1 (2.2.16)
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: rcovell at rolet dot com
New email:
PHP Version: OS:

 

 [2001-03-02 16:23 UTC] rcovell at rolet dot com
To reproduce:
1) ./configure --with-apxs=/usr/local/apache1317/bin/apxs
--with-mysql=/usr/local/mysql --enable-debug=no
--enable-track-vars=yes --with-gdbm --enable-ftp --with-xml
--with-curl --with-openssl --with-pfpro --with-zlib=/usr/lib

NOTE 1: I have placed the path to the pfpro lib and it did not make a difference.

NOTE 2: I have also configured it with only pfpro to verify that it was not any other modules and it did not make a difference.

2) make
This is the result
root@server5:/usr/local/phpApache/php-4.0.4pl1# make > make.out
pfpro.c: In function `php_if_pfpro_version':
pfpro.c:129: warning: initialization makes pointer from integer without a
cast
root@server5:/usr/local/phpApache/php-4.0.4pl1#

NOTE: I sent the output into make.out so I could just see the errors.

3) make install
4) cd to apache install dir and run configtest.  It will give the following result:
root@server5:/usr/local/phpApache/php-4.0.4pl1# ../../apache/bin/apachectl
conf
igtest
Syntax error on line 213 of /usr/local/apache1317/conf/httpd.conf:
Cannot load /usr/local/apache1317/libexec/libphp4.so into server:
/usr/local/apache1317/libexec/libphp4.so: undefined symbol: PNVersion
root@server5:/usr/local/phpApache/php-4.0.4pl1#

I believe the error is in the ext/pfpro.c code (../php-4.0.4pl1/ext/pfpro/pfpro.c)----
/* {{{ proto string pfpro_version()
   Returns the version of the Payflow Pro library */
PHP_FUNCTION(pfpro_version)
{
        if (ZEND_NUM_ARGS() != 0) {
                WRONG_PARAM_COUNT;
        }

        RETURN_STRING(PNVersion(), 1);
}

I have gone in and commented out all the lines in pfpro.c and php_pfpro.h that referenced the pfpro version function.  Doing this and repeating the above steps allowed me to get apache up and running but it would seg fault at times so this is not a very good solution.  I have not submitted a gdb because I can't get it start without my commented changes.  Additionally, if I don't build it wil pfpro it configs, makes, and runs fine.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-03-04 17:45 UTC] rcovell at rolet dot com
I believe the problem is that we are using the V3 of the pfpro sdk and that php is on V2.11.  Are there any plans to include V3 support in the near future?
 [2001-04-25 02:32 UTC] jdonagher@php.net
Since I work on this extension for my company, work on 
this will progress when Verisign converts our account from 
v2 to v3. I've received notification of this; it will be 
within the next couple weeks.

 [2001-04-25 02:34 UTC] jdonagher@php.net
As a sidenote, commenting out the pfpro_version function 
will not solve the problem. There are other features that 
the v3 SDK implements which this extension does not. The 
extension does need some work.

 [2001-05-01 01:11 UTC] jdonagher@php.net
Support for version 3 is now present in the CVS version of 
PHP. Note: You will need to do this in your script for the 
time being:
#putenv('PFPRO_CERT_PATH=/path/to/verisign/sdk/certs');

Please try the CVS version if you can; if the segfaulting 
persists please compile with debugging on (--enable-debug) 
and send me a backtrace, and you're full Apache and PHP 
configure lines, and re-open this bug.


 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu Dec 02 23:03:35 2021 UTC