php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #9450 File uploading problem
Submitted: 2001-02-25 21:32 UTC Modified: 2001-02-27 08:12 UTC
From: korba at korbs dot pl Assigned:
Status: Closed Package: HTTP related
PHP Version: 4.0.4pl1 OS: Linux/RedHat 6.2
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: korba at korbs dot pl
New email:
PHP Version: OS:

 

 [2001-02-25 21:32 UTC] korba at korbs dot pl
Ok, I have simple form:
<form type="multipart/form-data" action="./upld.php" method="post">
...
<input type="file" name="userfile">
...
</form>

and upld.php contains something like this:
...
copy($userfile, $newfile);
...

The problem is:
$userfile, instead of temporary file name, contains original senders's local file name
$userfile_name is empty

If I didn't provide enought information, please drop me a note :-)
Good luck,
Korba

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-02-26 09:52 UTC] korba at korbs dot pl
Ooops, I'm very sorry, it was my mistake... Of course everthing works fine, except when uploading picture, it contains "Content-type: ...." at the beginnig. But I guess it's different bug-report.
 [2001-02-27 08:12 UTC] sniper@php.net
This is fixed in CVS. Try a CVS snapshot from http://snaps.php.net/

--Jani

 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Fri Apr 19 23:01:25 2019 UTC