php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #945 Invalid doc_root in INI causes dump to browser
Submitted: 1998-11-23 11:34 UTC Modified: 1999-11-14 03:38 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: sprinkle at explorers dot com Assigned:
Status: Closed Package: Other
PHP Version: 3.0.5 OS: BSDI Unix
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: sprinkle at explorers dot com
New email:
PHP Version: OS:

 

 [1998-11-23 11:34 UTC] sprinkle at explorers dot com
In configuring PHP, I inadvertently typed '\' instead
of '/' in the doc_root string.  The problem is that 
PHP sent a dump of its executeable to my browser.
PHP is being run in CGI mode under APACHE.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [1999-11-14 03:38 UTC] joey at cvs dot php dot net
This can be fixed by editing you php3.ini, and adjusting the doc_root,
if the doc_root is really the issue
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Fri May 24 19:01:29 2024 UTC