php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #9410 php segfaults when ImageString-ed text overflows available image space
Submitted: 2001-02-22 15:38 UTC Modified: 2001-06-03 07:15 UTC
From: phpbugs03 at smayw dot nask dot com Assigned:
Status: Closed Package: GD related
PHP Version: 4.0 Latest CVS (22/02/2001) OS: Linux 2.2.17 RedHat 6.2
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: phpbugs03 at smayw dot nask dot com
New email:
PHP Version: OS:

 

 [2001-02-22 15:38 UTC] phpbugs03 at smayw dot nask dot com
Apache child segfaults (according to main apache log, but no mention in virtual site log) when ImageString text cannot fit on the ImageCreate-d canvas.

The segfault happens in:

http://www.tpsa.com/text-segfault.phps
(the .php is useless since all it does is segfault)

but not in:

http://www.tpsa.com/text-segfault-fixed.php

The _only_ difference is:
$ diff text-segfault.php text-segfault-fixed.php
3c3
< $im = @ImageCreate (50, 100)
---
> $im = @ImageCreate (100, 100)
$

Output of phpinfo(); is at http://www.tpsa.com/php.php
and the CVS tree has been synced Thu Feb 22 15:31:59 EST 2001

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-06-03 07:14 UTC] sniper@php.net
This should be fixed in PHP 4.0.6. Please try the
latest release candidate (RC2) from:

http://www.php.net/~andi/php-4.0.6RC2.tar.gz

--Jani

 [2001-06-03 07:15 UTC] sniper@php.net
I can't reproduce this with PHP 4.0.6RC2..

 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sat Nov 16 23:01:41 2019 UTC