php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #9409 ImageString rotates / mirrors / mangles text
Submitted: 2001-02-22 15:18 UTC Modified: 2001-06-03 07:13 UTC
From: phpbug02 at smayw dot nask dot com Assigned:
Status: Closed Package: GD related
PHP Version: 4.0 Latest CVS (22/02/2001) OS: Linux 2.2.17 x86 RedHat 6.2
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: phpbug02 at smayw dot nask dot com
New email:
PHP Version: OS:

 

 [2001-02-22 15:18 UTC] phpbug02 at smayw dot nask dot com
ImageString-ed text is rotated and/or mirrored (around center of text possibly?).

Looks similar to http://bugs.php.net/bugs.php?id=8544

http://www.tpsa.com/text.php

Here the text is totally mangled/duplicated/etc:

http://www.tpsa.com/text2.php

and the corresponding .phps

phpinfo for above available at http://www.tpsa.com/php.php
the cvs was checked out on Thu Feb 22 14:52:22 EST 2001
This bug is also present in 4.0.4pl1

I did try different fonts and am sure I do not have any old libgd libraries or include files.

Thanks for any and all help/suggestions.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-06-03 07:13 UTC] sniper@php.net
This should be fixed in PHP 4.0.6. Please try the
latest release candidate (RC2) from:

http://www.php.net/~andi/php-4.0.6RC2.tar.gz

--Jani

( I can't reproduce this..)

 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sat Nov 16 20:01:38 2019 UTC