php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #9354 Doesn't support UNC paths
Submitted: 2001-02-20 11:32 UTC Modified: 2001-04-27 19:46 UTC
From: km at altavista dot net Assigned:
Status: Closed Package: Directory function related
PHP Version: 4.0.3pl1 OS: Win32
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: km at altavista dot net
New email:
PHP Version: OS:

 

 [2001-02-20 11:32 UTC] km at altavista dot net
On Win32, this does not work;

$d = dir("//machine_name/share_name");
echo "Handle: ".$d->handle."<br>\n";
echo "Path: ".$d->path."<br>\n";
while($entry=$d->read()) {
	echo $entry."<br>\n";
}
$d->close();

On Win32, UNC paths are the expected format for networked filesystems, especially for any software running as a service (i.e. webservers)

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-02-21 04:21 UTC] sniper@php.net
Duplicate of #6554


 [2001-04-27 19:46 UTC] sniper@php.net
This is fixed in CVS. Wait for PHP 4.0.6 to be released.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Tue Dec 01 13:01:47 2020 UTC