php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #9237 date function parameters won't work on PWS
Submitted: 2001-02-13 05:26 UTC Modified: 2001-02-20 02:28 UTC
From: ajandris at parks dot lv Assigned:
Status: Not a bug Package: Date/time related
PHP Version: 4.0.4pl1 OS: NT 4.0 wrkst, win98
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
16 - 4 = ?
Subscribe to this entry?

 
 [2001-02-13 05:26 UTC] ajandris at parks dot lv
On linux (built in) and IIS 4.0 (cgi vers) on nt4.0 wrkst i can use function for example:
 function getThisMonth(){
  $dat=getdate();
  return $dat[mon];
 }
 without problem.
On pws it reproduces error (description I don't remember -> it happens at home)
I should put mon in double quotes '"'. Then it works.
This error happens with other parameters like nmon, year ...
With quotes it works on linux and IIS 4.0 too.

Thanks,
Andris

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-02-13 12:44 UTC] cynic@php.net
I bet the text of the errmsg is somethign like this:

Warning:  Use of undefined constant x - assumed 'x' in ... on line ...

this is caused by error_reporting set high enough to trigger this warning. 
 [2001-02-20 01:56 UTC] ajandris at parks dot lv
Yes, the message I received is like this ...
I didn't receive that before.

Suggestions: don't set error reporting by default so high in installation wizard for win32 binaries.

Thanx,
Andris

 [2001-02-20 02:28 UTC] derick@php.net
The usage of $dat[mon] is not the way it shoudl work. Without the "'s, it's not possible for PHP to see whether mon is a constant, or an index. Therefore you should always use "mon" if you want mon to be the index of your array.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Fri May 24 20:01:29 2024 UTC