php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #9160 When using the include() function, the file being included is cached by php
Submitted: 2001-02-07 13:14 UTC Modified: 2001-03-16 17:07 UTC
From: john at 3050ad dot co dot uk Assigned:
Status: Closed Package: Unknown/Other Function
PHP Version: 4.0.3pl1 OS: Redhat Linux 7.0 Kernal 2.2.16-2
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: john at 3050ad dot co dot uk
New email:
PHP Version: OS:

 

 [2001-02-07 13:14 UTC] john at 3050ad dot co dot uk
When I use the include() command to include one PHP script inside another, the script that is being incuded gets cached by PHP for a long period of time. I have not experienced this in any previous version of PHP4, using exactly the same scripts. When I edit, or even delete the script thats being included, PHP still behaves as if the script is still there and hasn't been modified.

The final page which PHP outputs to the the browser is NOT being cached, I have verified this by making a change to the script that is using the include() command to include the 2nd script.  When I change that first script the change shows up in the browser, so it is clear that the page is not being cached. The only thing being cached is that second script which is include()ed from the first one.

The output of phpinfo() running on my server can be viewed at this url:

http://salvador.ida-corp.net/test.php

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-02-14 14:09 UTC] sniper@php.net
Are you sure it isn't the browser that caches the page? Try reloading the
page with pressing shift key down and click reload. That way it shouldn't
get cached. With which browser did you try with? Have you tried lynx? :)

--Jani

 [2001-03-16 17:07 UTC] sniper@php.net
No feedback, can't reproduce.

--Jani

 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed Jul 06 08:05:45 2022 UTC