php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #9147 bugs in post using multipart/form-data
Submitted: 2001-02-07 09:42 UTC Modified: 2001-03-16 17:00 UTC
From: hwlee at phys dot chungbuk dot ac dot kr Assigned:
Status: Closed Package: Unknown/Other Function
PHP Version: 4.0.4pl1 OS: RH Linux 7.0
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: hwlee at phys dot chungbuk dot ac dot kr
New email:
PHP Version: OS:

 

 [2001-02-07 09:42 UTC] hwlee at phys dot chungbuk dot ac dot kr
Hello!
I installed "php-4.0.4pl1-3.i386.rpm" which
can be obtained from "ftp://updates.redhat.com".

When one try to send variables using multipart form,
one always get strings with additional CR LF
characters at the front.

Below I enclose two short files.
Please try them.

--- a.html ------
<form method=post enctype="multipart/form-data" action="b.php">
Data:<input name=aa value="00000">
</form>

--- b.php -------
<?
$aahex = bin2hex($aa) ;
echo "$aahex";
?>

------------------

Where I submit the form (a.html) with
Data = 00000, I get "0d0a3030303030".
Here I can see extra CR LF ("0d0a").

When I used older version ( 4.0.3),
I didn't experience such things.

Thank you.

Haewon Lee
Physics Dept.
Chunbuk Nat'l Univ., Korea

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-02-07 20:47 UTC] hwlee at phys dot chungbuk dot ac dot kr
Hello!
I installed "php-4.0.4pl1-3.i386.rpm" which
can be obtained from "ftp://updates.redhat.com".

When one tries to send variables using multipart form,
one always get strings with additional CR LF
characters at the front.

Below I enclose two short files.
Please try them.

--- a.html ------
<form method=post enctype="multipart/form-data" action="b.php">
Data:<input name=aa value="00000">
</form>

--- b.php -------
<?
$aahex = bin2hex($aa) ;
echo "$aahex";
?>

------------------

When I submit the form (a.html) with
Data = 00000, I get "0d0a3030303030".
Here I can see extra CR LF ("0d0a").

When I used older version ( 4.0.3),
I didn't experience such things.

Thank you.

Haewon Lee
Physics Dept.
Chunbuk Nat'l Univ., Korea


 [2001-02-15 19:56 UTC] sniper@php.net
Please try the latest CVS snapshot from http://snaps.php.net/ as this 
works for me just fine. (you have to compile it yourself though)

--Jani

 [2001-03-16 17:00 UTC] sniper@php.net
No feedback, works for me with latest CVS.

--Jani

 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed Jul 06 00:05:46 2022 UTC