php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #9134 configure: error: Invalid Apache directory - unable to find httpd.h under /usr/
Submitted: 2001-02-06 14:09 UTC Modified: 2001-02-14 13:07 UTC
From: pablosof at net-alliance dot net dot ar Assigned:
Status: Not a bug Package: Installation problem
PHP Version: 4.0.4pl1 OS: Slackware Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: pablosof at net-alliance dot net dot ar
New email:
PHP Version: OS:

 

 [2001-02-06 14:09 UTC] pablosof at net-alliance dot net dot ar
It is the script that I write to ./configure the system:

 ./configure --with-apache=/usr/local/apache/include/httpd.h --enable-ftp --with-mysql

And it is the result

configure: error: Invalid Apache directory - unable to find httpd.h under /usr/local/apache/include/httpd.h

(The problem is that the path to httpd.h is correct, and the file is where I say)

THANKS

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-02-14 13:07 UTC] sniper@php.net
Please READ the INSTALL file. If you use --with-apache you're 
compiling PHP as static module ie. you should point the path to the apache SOURCES. 

--Jani

 [2002-09-16 04:22 UTC] dan_dipiro at hotmail dot com
I tried that with no success.  Do you mean the base source directory eg.  /var/pkg/apache_1.3.26  or the actual sub directory that has the httpd.h file ?
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed Aug 10 20:05:44 2022 UTC